Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

access to smarttphone memory impossible

Started by lukand, June 13, 2024, 01:33:05 PM

Previous topic - Next topic


Yesterday morning I was able to transfer some files to the memory card in my smartphone. Regrettably, the same day after noon it became impossible. I suspect than an system update caused the problem. Is it possible to fix it somehow?


Hi lukand, :-)

I'm guessing it's going to be difficult for anyone to be able to help you unless you provide more information. Some questions / comments:

1. There's a way to look at the history of your system's updates, which might help your troubleshooting if that's the issue. If you don't know how to do this, I'm guessing it wouldn't take long to find out how via an online search (BTW, using 'debian' rather than 'sparky' might give you more helpful hits). (You can also check out the wiki for one or more terminal commands you can run if you suspect that something went wrong with your system updates and/or there are broken packages, etc.)

2. How are you transferring these files? USB? Some sort of wireless connection? If there are options on the phone for choosing whether you want to use a connection for file transfer or something else, are those set appropriately? If there are multiple ways that you can transfer files, have you tried all of them to see if any work?

3. Have you tried doing a restart?

4. When you say it's impossible to transfer files, what does that actually mean? Or in other words, what are the contextual details? Is your PC not able to see the device at all when it's connected? Does it see it, but the transfer doesn't work for some reason? Does it attempt to do the transfer and then fail?

5. Do you have enough space on the memory card for the files you're trying to transfer?

6. What's the make/model of your smartphone?

7. What type of memory card is it?

8. Is the phone serving some other purpose while you are trying to transfer the files? (eg. I have a phone that can be used to provide internet to a PC via USB tethering, but when you are doing this you're not able to use that USB connection for file transfers).

I'm not sure that each of the above is actually relevant to your problem, but those are the types of things I'd be looking at if I was trying to troubleshoot it.



I tried to copy some files from PC to the memory card via USB. Unfortunately, unlike in the past, there is no way to see the icons which provide the possibility to access the memory card and internal smartphone memory as well. Despite restart, the situation is the same. There is much free space on the 512 GB Samsung memory card. The only mode I applied whilst connecting Fairphone 4 was to transfer files via USB


Besides what I've already mentioned, here's a couple other things that might help:

1. Have you checked the support and forum pages of the Fairphone website? It looks like there might be some ideas there.

2. To see if your system is recognizing the phone, you can try listing the USB devices on your system with the following command:
lsusbIf you're not sure how it will be listed, run the command with the phone unconnected and note the output; then connect the device and run it again and compare the output to see what is new. If nothing is new, then your system is not recognizing it for some reason.

3. If you have more than one USB port, you could try others to see if they work.

4. You could also look at the last part of the output of the following command immediately after connecting the phone to see if there are any warnings or errors that might be related:
5. Also, when you're looking for help on this or other similar forums, it would be good for you to include as much relevant information as possible. You can use the command-line tool 'inxi' and its various options to generate general / specific / relevant information about your system that you can then copy from the terminal (Shift + Ctrl + C) and paste into your post here using the code markers for easier readability. (Hover over the icons above where you're writing till you see the one marked 'Code', click on that and it should give you code markers like this: "code""/code" except with bracket markers in place of the quote markers. Then just paste the inxi output from the terminal between the code markers so it will show up correctly [you can use the preview option to check it's working as expected].) The 'inxi' tool has lots of different options -- here is just one example:
inxi -Frz(The '-F' option includes basic information for quite a few parts of your system, the '-r' option provides details on your repos, and the '-z' option filters out some things for privacy / security, which is probably a good idea when posting in public spaces like this forum.)

View the most recent posts on the forum