Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

SparkyLinux 6.7 (Po-Tolo) LXQt install on new Dell 5424 Toughbook

Started by garvint, May 16, 2024, 11:14:18 PM

Previous topic - Next topic


Today I purchased a new Dell 5424 Toughbook Rugged Laptop Core i7-8650u 32GB Ram 1TB SSD.

I tried with a USB boot installing my particular favorite "SparkyLinux 6.7 (Po-Tolo) LXQt"

The Dell BIOS can load the USB, changing latency , CSM enabled, SecureBoot disabled.

Sparky finds the hard drive partition and connects to wifi perfectly to install (with swap and hiberernate)

After that there is no way i can find to boot that hard drive with booting to Grub in the Master Boot.

Annoyingly Ubuntu-Mate installs faultlessly, which i think is something to do with a digital signature. 


Are you using a multi-boot setup? If so, it might be helpful to mention what other OS's you're using. Could this have something to do with where you're having Grub installed and/or whether you do a grub update afterward (i.e. which might scan for OS's on the machine to include in the grub menu). Also, are you using more than one hard drive? If so, using BIOS settings for boot order or using a boot options menu to choose the device to boot from might come into play. Might also be helpful to detail the similarities and differences between the Ubuntu install that works and the Sparky one that doesn't, as well as any relevant error / warning messages you see along the way. For some of the info related to your system, it might be helpful to use the 'inxi' utility with appropriate options to generate a collection of information about your system that you can post (as 'code') here. Can't guarantee I or others will be able to give you an easy fix / answer on this, but doing some / all of the above might give someone a better chance of understanding your setup there.

Edit: Here are some additional ideas if you haven't already tried them:
1. Double-check iso integrity.
2. Compare the Ubuntu installer and Sparky installer for any relevant differences. Depending on your Sparky version / iso, there may be an alternate installer you can use to produce an install that boots / works. You can search the wiki and/or forum for info on this.
3. If you have a system that this Sparky works on, you could compare that system and the problem system for any relevant differences.
4. You could try one or more different versions of Sparky; if one of them works, you could compare it with your preferred version for any relevant differences.
5. Not sure how you would go about doing this, but you could try to find out whether there is anything about your BIOS / hardware that might be keeping the Sparky installer from doing some necessary setup but without causing it to produce an error message.
6. If it's a Grub-related issue, you could try using a live UFD (USB flash drive) to repair / reinstall Grub. Not sure of your proficiency with Linux and Sparky, but there's a live Sparky Rescue iso that has a variety of tools for troubleshooting and fixing problems.
7. You could do some online searches with the 'make' / 'model' of your system and/or any relevant parts, along with the keyword 'debian' and relevant version number that your Sparky is based on ('11'?), which might help you see if others have had a similar problem. With new systems, there's always a chance that older software isn't compatible with them or doesn't support them in some way. In that case, you may need to go with a newer version of Sparky, unless you can get by with tweaking Grub and/or the iso data and/or the installer in some way to make it work. Related to this, it might be worth looking into whether the Ubuntu that works is based on the same Debian version as the Sparky you're trying to install. If not, you could try installing an Ubuntu version that is based on the same Debian version to see what happens and then compare similarities and differences, etc. to see if you can figure out where to focus your troubleshooting efforts. Or similarly, try installing a Sparky version that uses the same Debian version base as the Ubuntu you know works.

View the most recent posts on the forum