Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

lightdm won't start

Started by Splinx64, February 04, 2024, 10:23:52 AM

Previous topic - Next topic


Hello everybody,

for about two weeks I have the problem that I cannot login via lightdm. The screen remains black, while booting there is not the splash screen.

In this situation I only have access to my system via SSH. Changing to another console doesn't work.

But, when I boot into recovery mode and instead of login as root, but go continue with CTRL+D, than lightdm starts like normal.
When I in recovery mode log in as root and call 'systemctl start', than lightdm starts like normal too and I can log in as user.

In last time I did following things:

- de- and reinstalled nvidia driver
- de- and reinstalled lightdm and lightdm-gtk-greeter
- initramfs updated

But unfortunately nothing of them helped.

Here some outputs of commands, I did in normal boot mode, when lightdm didn't work.

~$ inxi -SG
  Host: haus Kernel: 6.6.13-amd64 arch: x86_64 bits: 64 Console: pty pts/1 Distro: SparkyLinux 8
  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia v: 525.147.05
  Device-2: Microsoft LifeCam HD-3000 driver: snd-usb-audio,uvcvideo type: USB
  Display: server: v: driver: X: loaded: fbdev,modesetting,nouveau,nvidia,vesa
    gpu: nvidia tty: 128x45
  API: EGL v: 1.5 drivers: nvidia,swrast platforms: gbm,surfaceless,device
  API: OpenGL Message: GL data unavailable in console for root.

'haus' is my host name.

~$ systemctl status lightdm
● lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; preset: enabled)
     Active: active (running) since Sun 2024-02-04 09:19:53 CET; 6min ago
       Docs: man:lightdm(1)
   Main PID: 1378 (lightdm)
      Tasks: 5 (limit: 38268)
     Memory: 9.9M (peak: 10.4M)
        CPU: 65ms
     CGroup: /system.slice/lightdm.service
             ├─1378 /usr/sbin/lightdm
             └─1395 /usr/lib/xorg/Xorg :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Feb 04 09:19:53 haus systemd[1]: Starting lightdm.service - Light Display Manager...
Feb 04 09:19:53 haus systemd[1]: Started lightdm.service - Light Display Manager.

~$ dkms status
nvidia-current/525.147.05, 6.6.13-amd64, x86_64: installed

~$ systemctl get-default

In this time I also installed SLiM. It works fine, without any problems, while booting the splash screen also appears. But I prefer lightdm

Maybe anybody of you have a solution to solve my problem.

Thank you forward for your help.


Oh, how can I edit the topic title? I did a spelling mistake.
Already found how to ... and done.


I would like to add something else.

I use this Sparky Linux system on this computer for more about three years with the same hardware and on my older computer before too.

Appr. two weeks ago was an update via Sparky-Upgrade-tool. Up to this point in time lightdm and lightdm-gtk-greeter worked perfectly. I believe, in this time kernel 6.5.0-5 and 6.5.0-4 were installed. Since that time I deleted them.
On more information. MATE is my desktop environment.

Maybe, this information helps to find a solution for my request.


And one more information.

I also tried to run lightdm with slick-greeter. But, the result is the same - lightdm don't want to start.


QuoteBut, when I boot into recovery mode and instead of login as root, but go continue with CTRL+D, than lightdm starts like normal.

Plymouth update maybe?

Try disabling Plymouth by removing quiet splash from /etc/default/grub

Browse for Disable Plymouth to get more info if needed.
21grams >> light in flight


Hello 21grams,

thank you for your answer.

Yes, disabling "splash" in the kernel command line was a good idea. That works. YEAAAHHHH!

Unfortunately, reinstalling all of plymouth packages didn't work. When I do that, I get a lot of messages

cp: warning: behavior of -n is non portable and may cange in future; use --update=none instead
And on the end of all:

insserv: FATAL: service udev has to be enabled to use service plymouth
But on first step the first solution is usable.


The cp warning, debian will no doubt sort as it is their own doing.

I have not used plymouth for many years as my nvidia proprietary driver installs always shut me out and in testing, it's another slap something else in there situation (old habits).

21grams >> light in flight


OK, but I wonder. Until a fortnight ago "splash" wasn't disabled and I could log in via lightdm. Yes, the "splash" screen wasn't visible, but that didn't bother me.

I think, it will work again, when there is an update available for plymouth - one day.

Of course, thank you for your help.


You're welcome.

For clarity (my bad), a Plymouth update came through to testing approx 3 weeks ago. To inspect further of why it is an issue for a some setups? - humongously above my top2 inches.

21grams >> light in flight


Hm, maybe the current release of plymouth has a tiny bug. It can happen. But we hope, it will be fixed soon.

View the most recent posts on the forum