Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Hyprland - binary in PATH not found even if it's there [SOLVED]

Started by PerfMonk2, December 13, 2023, 04:58:24 AM

Previous topic - Next topic



I have successufully compiled nwg-launchers the install script creates some programs in /usr/local/bin directory.  I'm using Hyprland and I would like to bind a key to nwggrid (it shows a nice app menu).  When I add the binding in the config file I immediately get a warning from hyprland that it doesn't find nwggrid.  I tried putting the name with the complete path to get same result.  But if I call nwggrid from the shell it opens and works OK.  The permissions of the file are the same of the others programs in the same directory.

Any idea why an executable program would not work in Hyprland from a key bind ???

I added this line to the hyprland config:
bind = $mainMod  N, exec, '/usr/local/bin/nwggrid'

The permissions are :
ls -al /usr/local/bin/nwggrid
-rwxr-xr-x 1 root staff 659736 12 déc 13:30 /usr/local/bin/nwggrid


PS: I have other key binds that works perfectly. Only this one doesn't work I don't know why ???


Answering my own question :=)

I have found the culprit.  There was a coma missing after the bind instruction in config.

I wrote : bind = $mainMod  N, exec, '/usr/local/bin/nwggrid'

I should have written: bind = $mainMod,  N, exec, '/usr/local/bin/nwggrid'
The error message was
QuoteConfig error at line nnn, Invalid dispatcher requested "/usr/local/nwggrid" does not exist

It induce me in error since the problem was not nwggrid but that is wasn't recognising the exec dispatcher since it was not at the right place because of the missing coma ...  Not that clear.

Anyway I'll mark the case SOLVED.

View the most recent posts on the forum