Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

After update Grub does not find Windows 10, again

Started by corsair, October 11, 2023, 09:50:14 PM

Previous topic - Next topic


Hi all,

In May I encounter the same problem and solved it - because of pavroo.
This time i tried the same solution,
add GRUB_DISABLE_OS_PROBER=false at the end of /etc/default/grub file
and then sudo update-grub

but now i have an error
/usr/sbin/grub-mkconfig: 1: /etc/default/grub: �#: not found

I'd prefer not to have to reinstall the system...

Thank you


Hi Corsair,

The error you're  now getting is no big deal ==> no need to reinstall the whole system.
Just pay some attention to this :#: not found



Hi everyone

Yesterday I updated Sparky to 7.1 Mate orion Belt kernel 6.1 0 13-amd64 Apple iMac 2010

The install itself ran fine and Sparky ran well for about 10 minutes
I had Firefox browser open and it began to spawn non stop duplicate browser windows
The Space key locked itself in repeat mode and ran wild/keyboard locked up

System then became un-responsive and I had to do a hard shutdown

On reboot, (several tries) I got a boot error stating the encrypted disk could not be found
Tried several work-arounds and suggestions on here but had no luck                     
Had to erase and re install Sparky from scratch,as Grub Boot would not repair

Luckily I could run a Live Sparky from a USB and retrieve files from the hard disk before doing an new install

I am still getting the occasional runaway Space bar cursor problem, using a newish mechanical keyboard that otherwise works fine
Not much fun,but at least I am up and running again!

View the most recent posts on the forum