Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[solved] sudo dpkg –configure -a throws error after upgrading sparky 7 to 8

Started by Oulik, September 16, 2023, 05:56:56 PM

Previous topic - Next topic


During the upgrading from sparky 7 to sparky 8 the system got stuck at 93%
sudo dpkg –configure -a throws me an error.
What can I do?


Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Hi Pavroo.

I eventually fixed it by doing the following:

To fix broken packages on Debian-based distributions using APT:
1. Open the terminal by pressing Ctrl + Alt + T on your keyboard and enter:
sudo apt --fix-missing update
2. Update your system's package list from the available sources:
sudo apt update
3. Now, force the installation of the broken packages using the -f flag. APT will
automatically search for broken packages on your system and reinstall them from the
official repository.
sudo apt install -f


That did the trick, and it went on from where it stopped.

View the most recent posts on the forum