Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

cannot install gcc after upgrade

Started by COVID0, September 13, 2023, 06:42:57 AM

Previous topic - Next topic


I upgraded a PC from 5.16 to 6.7, and noticed that gcc is absent after upgrade. So tried to install compilers with build-essential and got this:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libr0 : Depends: libbinutils (< 2.31.2) but 2.35.2-2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I have no idea what libr0 is. Google and Bing turn up nothing about it.

View the most recent posts on the forum