Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Librewolf again. [Solved]

Started by SparkyBookworm, April 29, 2023, 08:10:57 PM

Previous topic - Next topic


Can someone explain this to me?

1) Using Sparky's "APTus Center" it says the current Librewolf version installed is 111.0-3.
2) Using "Synaptic" it says the current Librewolf version installed is 109.0-1.
3) The Librewolf browser says it is version 109.0. Although version 109 is an outdated version the browser still works fine.
4) During the daily 'System Upgrade' process whenever Librewolf appears in the Sparky Terminal it is not upgraded to version 111 and displays "kept back" status. Is Synaptic doing this "kept back" status? 
5) The current Flatpak version of Librewolf from Flathub is 112.0.1-2



apt policy librewolf
Zainstalowana: (brak)
Kandydująca:   111.0-3
Tabela wersji:
111.0-3 1001
1001 orion/main amd64 Packages

There is 111.0-3 in Sparky and app developer repos.

Synaptic must be refreshed via the "Refresh" icon before searching.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]



Using Synaptic I tried the "Reload" icon. The package still has a [!] icon and won't allow upgrade.  The good news is that Synaptic seems to recognize that I have version 109 installed, unfortunately the Sparky App Center appears to think I have version 111 installed?
The 'Force Version' option listed in the wiki for Synaptic I have not tried yet. Synaptic also says version 111 is testing.

If I 'mark for upgrade' using Synaptic an 'Unresolved dependencies' error comes up.


Right, the newest version 111 has too hight dependencies, thats why you can't upgrade it.
It is also temporary not available to make fresh install of librewolf on Sparky 7 so far.
librewolf : Requires: libnss3 (>= 2:3.88~) but 2:3.87.1-1 is installedHave to wait for upgrade in Debian repos.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks. It is good to know that it isn't just my own system, but is normal. Glad I didn't try to force the package upgrade, as it probably would have broke Librewolf.

These are my repos:

inxi -r

  Active apt repos in: /etc/apt/sources.list
    1: deb bookworm main contrib non-free
    2: deb-src bookworm main contrib non-free
    3: deb bookworm-security/updates main non-free contrib
    4: deb-src bookworm-security/updates main contrib non-free
    5: deb bookworm main non-free
  No active apt repos in: /etc/apt/sources.list.d/dropbox.list
  No active apt repos in: /etc/apt/sources.list.d/liquorix.list
  No active apt repos in: /etc/apt/sources.list.d/sid.list
  Active apt repos in: /etc/apt/sources.list.d/sparky-unstable.list
    1: deb [signed-by=/usr/share/keyrings/sparky.gpg.key] unstable main
    2: deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] unstable main
  Active apt repos in: /etc/apt/sources.list.d/sparky.list
    1: deb [signed-by=/usr/share/keyrings/sparky.gpg.key] core main
    2: deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] core main
    3: deb [signed-by=/usr/share/keyrings/sparky.gpg.key] orion main
    4: deb-src [signed-by=/usr/share/keyrings/sparky.gpg.key] orion main


Thanks Pavroo for 112 update!
A warning to other Librewolf users, the Librewolf update might nuke your bookmarks, so be sure to have bookmark backups before you update. This has never happened to me during a Sparky update before... Luckily I was able to fix this, although minus 1 day's worth of bookmarks.

View the most recent posts on the forum