Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

gdebi problem

Started by ercouper46@yahoo.com, November 17, 2022, 02:50:40 PM

Previous topic - Next topic

ercouper46@yahoo.com

I have installed 3 versions of Sparky over the last few days and everything is great except for gdebi problem which I can't get past.  After updating system, if I try to install a program from a .deb file I get the following message.... "You tried to install a file that does not (or no longer) exist." It doesn't matter what deb application I try to install the result is always the same. I even tried to run gdebi from terminal with $gdebi-gtk but get another error message which makes no sense. I distro hop often and have never ran into this problem. I very much like Sparky but if I can't solve this problem I will have to quit using it.  Thanks for any help.

I might add that the minimul gui edition (openbox) didn't have the problem until it was updated, both the semi-rolling and the stable versions had to problem after initial install (latest versions).
 

pavroo

Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ercouper46@yahoo.com

#2
I did a fresh install and DEBiTool worked until the first update (upgrade) and then stopped working. No matter which .deb file I tell it to open I get this message...... "Not a DEB package. Exiting...."

pavroo

So, there is a problem with the deb, I think.
Try in the dir you have the deb package:
sudo apt update
sudo apt install ./your-package-name-version.deb
Show me output if any problem.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ercouper46@yahoo.com

Yep, that works.  Thanks!

...it would be interesting to know what broke gdebi & debitool though. 

Thanks again, pavroo.

View the most recent posts on the forum