Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[Solved] Recent GRUB / Sparky Updates (~30hrs) Breaks Cataclysm-dda-sdl Package?

Started by SparkyBookworm, September 23, 2022, 04:41:39 AM

Previous topic - Next topic


Main issue: Please help me choose the best option for GRUB during the last routine update.

[I wasn't sure what forum category to post this question in as it pertains to the preinstalled GRUB and the game CataclysmDDA  that is available in the awesome Sparky App store. Preinstalled or Sparky applications Category? I am sorry in advance if this post is in the wrong subforum!]

So, during the recent Sparky updates it prompted for a Grub update, looks almost like this (except with blue border instead of purple):

The only text difference on on my screen being: "Configuring grub-efi-amd64"... "A new version (/tmp/grub.QnyrEIhqHe) of configuration file /etc/default/grub is available"...

Not knowing what to choose, I chose "keep the local version currently installed" option.

Thankfully, choosing this option did not break my system's ability to boot into XFCE's GUI.

However, Cataclysm DDA no longer functions, EXCEPT in the Cataclysm-dda-curses mode using terminal. I tried uninstalling & purging the old Cataclysm files and then reinstalling the game with same results. The game is of course a minor issue to me other than my concern with the recent Grub update (which is a potential major concern).

The only thing I can think of on my part that could be causing the issue other than the Grub option I chose during updates is that I have been tinkering directly within the Cataclysm's JSON files using root privilege in exploration attempts to test out modifications I've made with CDDA mods. I've been tinkering with with these JSON files without any issue until after this update. Cataclysm-dda-curses still works for me. I am left wondering: *is the problem only on my end?* or was it my choice in Grub, or my tinkering that broke Cataclysm-dda-sdl?

I am most concerned with my choice of updating the GRUB, should I have chosen any of those other various options, and NOT the "keep the local version currently installed" option?

My concern is obviously more so with my decision/choice for GRUB, though I am also kind of perplexed by the breakage of the CDDA gui too (it just won't start now unless in terminal's Ascii game mode). Cataclysm obviously is a much lower priority to me compared to that of the recent GRUB decision(s). What was/is the best choice for the GRUB option? I know Arch recently went through some Grub issues.


While waiting for the answer to the GRUB issue I made another attempt to remedy the CDDA issue.

Step 1) Once again uninstalled CDDA.
Step 2) In my folder home/username/, I deleted the .config and .cache related folders for the game Cataclysm.
Step 3) Deleted the leftover folder 'cataclysm-dda' using root, it had some leftover extra folders from github mods: /usr/share/games/cataclysm-dda/.
Step 4) Reinstalled CDDA.
Step 5) Uninstalled CDDA again.
Step 5) Reinstalled CDDA again.

Same result as before. I killed CDDA =(


"A new version of configuration file grub is available, but the version installed currently has been locally modified"

..Problem is, I don't recall modifying Grub or anything else in the '/etc/default/grub' directory.


The Cli-based Cataclysm works fine, but the SDL-interface does not.

I used Double Commander as root to search all leftover instances of 'Cataclysm' on my PC that I could find, deleting all instances including all 3 cataclysm-dda-XYZ files located in the /var/cache/apt/archives/ directory. All the hidden dot.files too. 

I downloaded another SDL-interface based app/game, called 'slashem-sdl' and that seemed to work. I don't play or edit that game so I deleted and installed other SDL-interface based applications I could find in the repository.

I installed gearhead-sdl and gearhead2-sdl and all their recommended depends. Also sdl-ball, and wolf4sdl too.

gearhead-sdl worked.
gearhead2-sdl worked.
sdl-ball worked.

wolf4sdl did NOT work.

Downloaded freeciv as it also seems to use sdl2. The Freeciv game worked.

So maybe this is some sort of SDL-related problem?

Only CDDA in Cli-mode works. Every other SDL-based game I tried except for wolf4sdl worked. Now I got to delete those games.

I am more concerned about the recent Grub updates, what is the correct option to choose for the Grub update?


Learning what SDL interface is for
Most of the other SDL apps I tested seem to be working so perhaps it isn't the problem. Maybe not updating the Grub is the culprit. Idk.


Link to Arch Grub issue:

Not sure what it means... if anything for Sparky and Debian Linux.

I restarted the PC so I could see the Grub screen again, this time I finally paid attention and at the top (the title) is the Grub version I currently have installed: Grub 2.06-3
I know it is silly I've never noticed this before. I wish there was a simple terminal command that worked to tell me current Grub version without having to restart.


I just ran Sparky GameOver edition in an emulator. All the strange preinstalled games I briefly tested worked. Wow, what a behemoth (glad I'm not much of a gamer)! Using GameOver I installed CDDA in the SDL mode and it did not run... So Cataclysm-SDL is broken in GameOver too. I guess it wasn't just me.

I went through about half dozen other Linuxes in an emulator. Sparky is still way up there as the most impressive (to me) with Fedora 36/37 in the visible distance... Gnome with extensions has come a long way since Gnome 40 for an ex-Windows user. Sparky reminds me of a modernized Windows 7 at its best but even better.

RebornOs made me realize why I don't miss using Arch, it is too messy. Pop!Os was underwhelming and confining version of Gnome as were many other distros I had mild hopes for were letdowns. Nobara meh.

The most impressive of the distros I went through was ReactOs running Windows MSI binaries abandonware Windows apps from pre-2000's. While it isn't a good daily use OS it is still simple to install legacy Windows stuff for nostalgia purposes maybe., it has some barely functional browsers I've never heard of too.

My only complaint with GameOver edition was it led to the same GRUB update during the lengthy updates which I chose the first option this time and installed GRUB into two locations (press space NOT enter for the (*) checkbox). Nothing broke but changes in GRUB spooks people that are still new-to-Linux. It is confusing for such an important Linux component to be handled in such a casual manner, it reminds me of maintaining kernels on Manjaro while using wifi hardware not yet fully supported by Linux.


I agree with you about those update prompts (keep, erase, flip a coin). I get nervous when I see those. I always take the default answer. So far I haven't had trouble. I think that would be stressful to newbies (I'm not a newbie and I get stressed).

Regarding distros, MX Linux is the only other one I'll use. It's not in the lightweight category like Sparky. But, it's not large either. Check that one out sometime. I think it has a Windows vibe (like back in Win98 days).

Regarding Windows, I've never used Zorin OS, but I remember a few years ago they advertised choose'able desktop themes that were designed to look like 98, XP, 7, 10. I got the impression that distro was geared toward Windows users more than other distros (just the look & feel. But, if there are a lot of Widows migrants using it, then there would probably be a lot of help there finding alternatives to Windows-only apps, or how to get one working in WINE). I did install it (the "Core" edition) once, and it was LARGE memory use. One of the largest I saw. But, Windows users are accustomed to that, so ... :) That was 3-5 years ago. It may have changed in its heaviness and choice of desktop themes. Linux Lite also has a history of serving the left-behind Windows users (unsupported, machines too old/slow to run the latest). It had an XP/7 look/feel, and lighter weight than Zorin. But, both are based upon Ubuntu. I like Sparky & MX because they're not. 


Through process of elimination the breakage of the game CataclysmDDA in SDL mode is definitely NOT because of the Grub update. I reinstalled the regular XFCE (not GameOver this time) rolling release of Sparky and went through the initial large update motions, installing the newer 2.06-4 version of Grub this time, then installed the Cataclysm package from the Sparky App-Store. The game in SDL-mode still doesn't start, however, it works as it should in Cli-mode. It is strange that many (>95%) of the other SDL-based games in the repository are still working on Sparky, so it may not be SDL-related either.


Cataclysm-DDA SDL mode is also malfunctioning in the Debian distro "SIDuction". Maybe has something to do with current Cataclysm being on Kernel 5.18 instead of the cutting edge 5.19 kernel? It is a guess.

Siduction handles the Grub update slightly more aesthetically (there is a Gui to click check marks on the boxes using your mouse, instead of having to use the 'space' key (you are possibly screwed if you instead press 'enter' key and might end up without Grub?), otherwise there are way more prompts during the update for Siduction, making Sparky more intuitive and easier to update, other than how Grub is handled. It is a minor quip. 

This was my first time using Siduction, it reminded me somewhat of Sparky but lacking the extra packages Sparky has, FAR less browsers and other useful apps for everyday desktop users. I initially thought Sparky was based on Testing but maybe it is Sid-based now? I love the recent updated browsers editions. For many users browsers are by far the most used application. I like not having to use Flatpak for my preferred browser. This alone makes Sparky special and as far as I can tell only Fedora does this, but only if you add third party repositories.. On Arch half the time the distro relies on flatpaks or other images. Otherwise you are going to rely on appimage, flatpak and snap for your specialty-browser updates. 

Sparky continues to impress.


I'm finding in many ways Sparky is easier to use than Windows 10. I was using Win10 primarily to run virtual machines to test various Linux(es) out. Now Sparky is on my machines instead instead of Windows doing the same thing and more.

I have a minimal-spec budget laptop (Linux's wifi support on this laptop is spotty). XFCE runs so well that with just under 7gig of available ram I can run the super-bloated Garuda Gnome "Xen" kernel Archlinux installation in virtualization on top of XFCE with a browser open, giving the majority of my RAM and hard disk to the temporary Arch installation. True, it barely runs the bloated Garuda on the 4gig of RAM I can give it, but Garuda is fancy I guess.

It seems that all the Arch Linuxes I've recently tested out in virtualization on Sparky bare metal are intentionally holding back the Cataclysm version to 0.F.3-2 instead of the newest version 0.F.3-5 (which seems to be the current version that Sparky is on). However, this is probably best choice for CDDA developers as the game still works 100% in the terminal curses mode. This obviously isn't the optimal way to learn how to play CDDA as the game is sort of a steep learning curve even in the Tiles SDL gaming mode.

If you haven't tried this game out and want to learn how to play it while using Sparky Rolling, I'd suggest installing the SnapD version (Cataclysm Flatpak doesn't exist yet), I think it has the beta version of Ultica tiles and the older CDDA inventory system, but you can still have a much easier time learning the game using tiles. I'm still getting used to understanding the terminal/cli version of CDDA myself. The tiles version is beautiful and the Cli version is humorously punishing.

This is good incentive to learn the game for terminal play.


I see 0.F.3-5 was rolled back to an earlier version which solves the issue. Cataclysm Bright Nights is another great solution too. Run 0.F.3-5 for Windows in Bottles or download the Linux version direct from the project's website. Bright Nights is an excellent solution if you don't like the massive content merging and removal taking place in the mainline Cataclysm.

View the most recent posts on the forum