Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

New to Sparky, fugitive from Windows, looking for Sigil support

Started by BobK99, August 06, 2022, 06:29:25 PM

Previous topic - Next topic

BobK99

Windows user since Windows V3.1, and passing acquaintance with UNIX and Linux. Now using SparkyLinux and trying to get my head around Sigil without BookView. I've tried to install PageView and have downloaded  PageEdit-1.7.0.tar.gz.sig - but when I doubleclick it it tries to open with Featherpad. Is there something else I need to install first? If I just need to point it to an 'Open With...' option, can you give me instructions for navigating to something that's already there( (And talk r e a l  s l o w ;-) )

AxL

Quote from: BobK99 on August 06, 2022, 06:29:25 PM[....] Now using SparkyLinux and trying to get my head around Sigil without BookView. I've tried to install PageView [....]



sudo apt update && sudo apt install pageedit

And, you're done


As reference, see:
Package: pageedit (1.9.10+dfsg-1) (ePub visual XHTML editor based on Sigil's Deprecated BookView)








Cheers !! 


BobK99

Thanks. Where does
sudo apt update && sudo apt install pageedit

 put PageEdit.exe? I've tried to grep it. But I need to brush up on grep as the command has been hanging for about 10 mins now and I think I may have told it search the entire Internet :-)



rollinbeaver

hi,

First: on Linux, there is no spoo.., uh, .EXE.
An application can have any name, provided it has the flag executable set.

On my (Mint XFCE 20) system,
$ apt-cache policy sigil
sigil:
  Installed: (none)
  Candidate: 1.6.0+dfsg-1
  Version table:
     1.6.0+dfsg-1 500
        500 file:/var/lib/local-apt-repository ./ Packages
     1.4.3+dfsg-1 500
        500 file:/var/lib/local-apt-repository ./ Packages
     1.2.1+dfsg-2 500
        500 file:/var/lib/local-apt-repository ./ Packages
     1.1.0+dfsg-1 500
        500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages
     0.9.18+dfsg-1 500
        500 file:/var/lib/local-apt-repository ./ Packages
     0.9.5+dfsg-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

This means that the Sigil (and PageEdit) from repositories are somewhat old.
You do have to follow the instructions "Sigil on Linux" on

https://sigil-ebook.com/sigil/download/

and, sorry to say so, download

https://github.com/Sigil-Ebook/Sigil/archive/refs/tags/{$actual version}.tar.gz

from

https://github.com/Sigil-Ebook/Sigil/releases

and build it from source.
This has been indeed painless and successful for me up to now.
The resulting .deb file i either install directly with dpkg, or rather put it in my local repository, so that apt can see it after

sudo /usr/lib/local-apt-repository/rebuild -f

Maybe that's a MINT thing, though.

As for PageEdit,

https://github.com/Sigil-Ebook/PageEdit/releases
https://github.com/Sigil-Ebook/PageEdit/

Hope this helps.

--
best regards, ever rollinbeaver

View the most recent posts on the forum