Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[Solved} Timeshift creates snapshot, but is not shown in the application

Started by Oulik, May 30, 2022, 08:35:42 PM

Previous topic - Next topic


The issue is solved because Timeshift was updated

See original post below

I have a weird problem with Timeshift. The application makes snapshots, but somehow in the GUI it is not possible to see them. However, the snapshots are physically made, complete with logs, but not visible in the GUI. Also, when I boot up with Sparky on a USB stick Timeshift cannot see the latest snapshots, the last snapshot it can see is from over 1 month ago. (2022-04-20)
Additionally, Timeshift seems to be making several snapshots because it doesn't recognize that it already made a snapshot.

Was guided into this solution

Downgrade rsync to version 3.2.3-4 and that makes Timeshift work again properly.
But with the next system update, it reverts rsync back to the latest version. (even when I locked the package in Synaptic)
Is there a way to hold the rsync to the older version?

A few settings, snapshot type RSYNC, Schedule, monthly keep 3

In Timeshift when I choose browse I can see the folders. Also, I can access the folders and go into the folders
In the last visible folder, (in the GUI (2022-04-20), I see that there are files called info.json and rsync-log-changes, but in the last created snapshots those files are missing. I did a Google search, and it also mentioned a missing json file, in an Arch forum, but it didn't give me a solution what to do about it.

I am running SparkyLinux 7 (Orion Belt)

View the most recent posts on the forum