Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Backintime is not lauching after last update

Started by rektal, April 24, 2022, 06:58:42 AM

Previous topic - Next topic

rektal

Backintime is not lauching after last update.
I think it's related to Python.

This is my terminal output:
rektal@Sparky:~$ backintime-qt
Traceback (most recent call last):
  File "/usr/share/backintime/qt/app.py", line 35, in <module>
    import qttools
  File "/usr/share/backintime/qt/qttools.py", line 47, in <module>
    import snapshots
  File "/usr/share/backintime/common/snapshots.py", line 34, in <module>
    import config
  File "/usr/share/backintime/common/config.py", line 32, in <module>
    import tools
  File "/usr/share/backintime/common/tools.py", line 1802, in <module>
    class OrderedSet(collections.MutableSet):
AttributeError: module 'collections' has no attribute 'MutableSet'

rektal

These are my last updates:
rektal@Sparky:~$ grep "upgrade " /var/log/dpkg.log
2022-04-23 06:04:58 upgrade ghostscript:amd64 9.55.0~dfsg-3 9.56.1~dfsg-1
2022-04-23 06:04:58 upgrade libgs9:amd64 9.55.0~dfsg-3 9.56.1~dfsg-1
2022-04-23 06:04:58 upgrade libgs9-common:all 9.55.0~dfsg-3 9.56.1~dfsg-1
2022-04-23 06:04:58 upgrade neofetch:all 7.1.0-3 7.1.0-4
2022-04-23 06:04:58 upgrade python3-gi-cairo:amd64 3.42.0-3 3.42.1-1
2022-04-23 06:04:58 upgrade python3-gi:amd64 3.42.0-3 3.42.1-1
2022-04-23 06:04:58 upgrade vokoscreen-ng:amd64 3.1.0-1 3.2.0-1
2022-04-23 13:04:43 upgrade libzimg2:amd64 1:3.0.3-dmo1 1:3.0.4-dmo1
2022-04-23 13:15:23 upgrade plexmediaserver:amd64 1.25.9.5721-965587f64 1.26.0.5715-8cf78dab3
2022-04-24 05:37:40 upgrade iproute2:amd64 5.17.0-1 5.17.0-2
2022-04-24 05:37:40 upgrade libatspi2.0-dev:amd64 2.44.0-3 2.44.1-1
2022-04-24 05:37:40 upgrade gir1.2-atspi-2.0:amd64 2.44.0-3 2.44.1-1
2022-04-24 05:37:40 upgrade libatspi2.0-0:amd64 2.44.0-3 2.44.1-1
2022-04-24 05:37:40 upgrade at-spi2-core:amd64 2.44.0-3 2.44.1-1
2022-04-24 05:37:40 upgrade libfile-listing-perl:all 6.14-1 6.15-1
2022-04-24 05:37:40 upgrade python3-automat:all 20.2.0-1 20.2.0-2

AxL


AxL

Quote from: AxL on April 24, 2022, 01:46:50 PMKnown bug, see:

Bug #1008653 - backintime-qt broken in sid after python upgrade - (Debian Bug report)




    Quote from: Debian FTP Masters[....] We believe that the bug you reported is fixed in the latest version of
    backintime, which is due to be installed in the Debian FTP archive.


    View the most recent posts on the forum