Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[Solved] Sound settings are not stored

Started by Oulik, March 20, 2022, 05:17:11 PM

Previous topic - Next topic


The latest firmware update 2022-06-07 07:43:58 upgrade firmware-sof-signed:all 2.1.1-1 solved the problem.
See original post below.

Hope you can help

I am having trouble storing the sound settings on an Acer Aspire 3 laptop.
For some strange reason, the sound settings are not stored.
The microphone keeps on defaulting to 68% which is way too loud when I want to record audio or talk on Facebook Messenger.
When I adjust the microphone input level down to 39% the level is fine, but once I restart the laptop it defaults to the same level again.
Also, when I adjust the output level to 100%, after restart is at the default level of 74% again.

The sound configuration is analog stereo duplex.
However, when I set the following configuration: (using the attached monitor as sound output) Digital stereo (HDMI) output + analog stereo input then the output level is stored, but still not the microphone.
So it seems that the problem is when using the internal audio (analog stereo duplex).

System profiler and benchmark tells me that the audio device is a : Intel Corporation Sunrise Point-LP HD Audio (rev21) prog-if 80)
Is there a solution for this issue?

So far I found out that: It seems to be a bug with machines with the sof audio driver, and it specifically mentions in this bug the Acer Aspire 5 (my laptop is the Acer Aspire 3 also with the SOF audio driver)

View the most recent posts on the forum