Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[solved] Error: could not find a distribution template for Sparky/bookworm

Started by ChuckEV, February 18, 2022, 10:34:25 PM

Previous topic - Next topic

ChuckEV

So I tried installing mkusb via Terminal according to directions on https://help.ubuntu.com/community/mkusb

ran this:
sudo add-apt-repository universe

got this:
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 95, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)   
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 91, in get_sources
    raise NoDistroTemplateException(
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Sparky/bookworm


and then ran this:
sudo add-apt-repository ppa:mkusb/unstable

and got the exact same error message again.

so what's a distribution template for Sparky/bookworm? and how do I get the right one and/or fix this error message?

pavroo

1. Do NOT add ubuntu ppa repos to Debian/Sparky - it can distroy your OS.
2. mkusb package is in sparky repos - so no need to add any additional repos.
3. to fix your issue with a template, uninstall package 'software-properties-gtk'
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

ChuckEV

Ah, then I might have a bigger problem, maybe.
When I first installed the OS, I was having trouble figuring out how to install packages and learning the ropes.
I added runescape to my repositories, I've been getting unusual messages related to that when I upgrade the system.

When I run:
apt-cache policy

I get this (search "runescape" to find the part I added):
Package files:
100 /var/lib/dpkg/status
     release a=now
1001 https://repo.sparkylinux.org orion/main i386 Packages
     release o=SparkyLinux,a=testing,n=orion,l=SparkyLinux,c=main,b=i386
     origin repo.sparkylinux.org
1001 https://repo.sparkylinux.org orion/main amd64 Packages
     release o=SparkyLinux,a=testing,n=orion,l=SparkyLinux,c=main,b=amd64
     origin repo.sparkylinux.org
1001 https://repo.sparkylinux.org core/main i386 Packages
     release o=SparkyLinux,a=core,n=core,l=SparkyLinux,c=main,b=i386
     origin repo.sparkylinux.org
1001 https://repo.sparkylinux.org core/main amd64 Packages
     release o=SparkyLinux,a=core,n=core,l=SparkyLinux,c=main,b=amd64
     origin repo.sparkylinux.org
1001 https://repo.sparkylinux.org unstable/main i386 Packages
     release o=SparkyLinux,a=unstable,n=unstable,l=SparkyLinux,c=main,b=i386
     origin repo.sparkylinux.org
1001 https://repo.sparkylinux.org unstable/main amd64 Packages
     release o=SparkyLinux,a=unstable,n=unstable,l=SparkyLinux,c=main,b=amd64
     origin repo.sparkylinux.org
500 https://content.runescape.com/downloads/ubuntu trusty/non-free amd64 Packages
     release o=content.runescape.com,a=stable,n=trusty,l=apt repository,c=non-free,b=amd64
     origin content.runescape.com
500 http://download.opensuse.org/repositories/home:/strycore/Debian_Unstable  Packages
     release o=obs://build.opensuse.org/home:strycore/Debian_Unstable,n=Debian_Unstable,l=home:strycore,c=
     origin download.opensuse.org
500 http://deb-multimedia.org bookworm/non-free i386 Packages
     release o=Unofficial Multimedia Packages,a=testing,n=bookworm,l=Unofficial Multimedia Packages,c=non-free,b=i386
     origin deb-multimedia.org
500 http://deb-multimedia.org bookworm/non-free amd64 Packages
     release o=Unofficial Multimedia Packages,a=testing,n=bookworm,l=Unofficial Multimedia Packages,c=non-free,b=amd64
     origin deb-multimedia.org
500 http://deb-multimedia.org bookworm/main i386 Packages
     release o=Unofficial Multimedia Packages,a=testing,n=bookworm,l=Unofficial Multimedia Packages,c=main,b=i386
     origin deb-multimedia.org
500 http://deb-multimedia.org bookworm/main amd64 Packages
     release o=Unofficial Multimedia Packages,a=testing,n=bookworm,l=Unofficial Multimedia Packages,c=main,b=amd64
     origin deb-multimedia.org
500 http://deb.debian.org/debian bookworm/non-free i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=non-free,b=i386
     origin deb.debian.org
500 http://deb.debian.org/debian bookworm/non-free amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
500 http://deb.debian.org/debian bookworm/contrib i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=contrib,b=i386
     origin deb.debian.org
500 http://deb.debian.org/debian bookworm/contrib amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
500 http://deb.debian.org/debian bookworm/main i386 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=main,b=i386
     origin deb.debian.org
500 http://deb.debian.org/debian bookworm/main amd64 Packages
     release o=Debian,a=testing,n=bookworm,l=Debian,c=main,b=amd64
     origin deb.debian.org
Pinned packages:


so, I'm guessing I shouldn't have done that (note taken). Is there steps I can take to correct that? Should I just leave it be?

As for mkusb, I took your advice and installed via Synaptic Package Manager.

also, when I look in Synaptic Package Manager and search for 'software-properties-gtk', it shows that it is not installed.

View the most recent posts on the forum