Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[SOLVED] minissdpd.service: Failed with result 'ex it-code'.

Started by ChuckEV, February 12, 2022, 03:23:09 AM

Previous topic - Next topic


I'm new to Linux and learning the ropes. I've been searching "minissdpd.service: Failed with result 'ex
it-code'." online trying to find a solution that I can understand, but I'm still pretty lost.

I've been running into this problem when trying to install LibreOffice in the synaptic package manager, and now I'm running into this error message while trying to do system update. I ran into this before I tried installing LibreOffice, can't remember what I was doing when I first ran into it.

I'm running SparkyLinux7 Gameover Edition on a 2012 Samsung laptop.


I don't know much about this, but my understanding is that minissdpd is used for UPnP discovery (and has a reputation for vulnerabilities too?). It can be be stopped:

systemctl stop minissdpd

That might enable you to install libreoffice. It can be disabled:

systemctl disable minissdpd

It can also be removed:

sudo apt-get remove minissdpd

It doesn't seem to be installed in the normal (not "gameover") Sparky 6.2 qt. I don't see it. So, apparently it's not required?

FWIW: I always disable upnp in the router. I don't want all my smart toasters, alexas, cortanas opening connections without me knowing about it. I create port forwarding for anything that needs it. (So, I don't think this service would do anything for me anyway.). I also connect those "internet of things" devices to a "guest" wifi which doesn't allow connected devices to see each other, nor my internal network devices. (I can enable guests to see each other, but not the internal network devices.).


Awesome! Thank you. I was denied when trying to disable it, so I just removed it. Update worked before I removed it without showing that error message, but I removed it as it sounded unnecessary. Then LibreOffice installed without any issues. Thank you for the advice!

View the most recent posts on the forum