Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

Error: could not find a distribution template for Sparky/bullseye

Started by KlemensPL, July 28, 2022, 11:13:03 PM

Previous topic - Next topic

KlemensPL

Hi!
I was trying to use sudo apt-add-repository non-free, but I get error raise NoDistroTemplateException(
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Sparky/bullseye

During research I found out that it's common error, but by the fixing it it's possible to harm the OS and could dependence on distribution. Thus, I decide to put the topic here. Do you know how to safely fix it to use 'non-free' for Sparky?
Thanks in advance!

Full terminal operations code:
sudo apt-add-repository non-free
Traceback (most recent call last):
  File "/usr/bin/apt-add-repository", line 95, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)   
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 91, in get_sources
    raise NoDistroTemplateException(
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Sparky/bullseye

cat /etc/os-release
PRETTY_NAME="SparkyLinux 6.3 (Po-Tolo)"
NAME="SparkyLinux"
VERSION_ID="6.3"
VERSION="6.3 (Po-Tolo)"
ID=sparky
ID_LIKE=debian
HOME_URL="https://sparkylinux.org/"
SUPPORT_URL="https://sparkylinux.org/forum/"
BUG_REPORT_URL="https://sourceforge.net/p/sparkylinux/tickets"

pavroo

You don't need to add non-free repos to sparky, already done as default.

But there is an issue as you found, not solved yet.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

View the most recent posts on the forum