Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[SOLVED]Calindori via Git, first attempt: New Linux User, please help if you can

Started by SparkyBookworm, December 18, 2021, 11:31:18 PM

Previous topic - Next topic


I have never compiled Git before and am also brand new to Linux. I'd like to use Calindori, it is not in Sparky's APTus or the Synaptic repositories. Nor can I find a Snapd or Flathub for Calindori.

Desktop Environment I'm using with Sparky7: KDE Plasma
Link to the compile directions I attempted to follow:
git clone
cd calindori
mkdir build
cd build
cmake ..
make -j$(nproc)
I have both 'make' and 'cmake' installed last time I checked. I will double check after getting a response.
Here is what happens in my terminal (I obviously have no clue what commands to enter to make 'cmake' work properly):

X@X-virtualbox:~$ uname -r
X@X-virtualbox:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Sparky
Description:    SparkyLinux 7 (Orion-Belt)
Release:        7
Codename:       bookworm
X@X-virtualbox:~$ git clone
Cloning into 'calindori'...
remote: Enumerating objects: 4147, done.
remote: Counting objects: 100% (848/848), done.
remote: Compressing objects: 100% (308/308), done.
remote: Total 4147 (delta 595), reused 786 (delta 538), pack-reused 3299
Receiving objects: 100% (4147/4147), 1.69 MiB | 2.06 MiB/s, done.
Resolving deltas: 100% (3067/3067), done.
X@X-virtualbox:~$ cd calindori
X@X-virtualbox:~/calindori$ mkdir build
X@X-virtualbox:~/calindori$ cd build
X@X-virtualbox:~/calindori/build$ cmake ..
-- The C compiler identification is GNU 11.2.0
-- The CXX compiler identification is GNU 11.2.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:16 (find_package):
  Could not find a package configuration file provided by "ECM" (requested
  version 5.62.0) with any of the following names:


  Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
  to a directory containing one of the above files.  If "ECM" provides a
  separate development package or SDK, be sure it has been installed.

-- Configuring incomplete, errors occurred!
See also "/home/s/calindori/build/CMakeFiles/CMakeOutput.log".
X@X-virtualbox:~/calindori/build$ make -j$(nproc)
make: *** No targets specified and no makefile found.  Stop.

Thanks in advance, anyone please let me know if more information is required to procure a response. These steps created a folder for calindori in my 'home' folder with some files included in it, but nothing is executable in its current state of being because I am clueless. Try to ignore the Code bars that automatically occur in the post as I don't yet understand how the forum's posting config works.


I will post the found [Solution] once I have it installed and seemingly stable on bare-metal budjet laptop. Right now I have Calindori working in Virtualbox in Sparky7 kdePlasma. Many extra packages are required before attempting to compile. Thanks to Ask Ubuntu.

In the meantime, as it may be awhile before I revive the budget laptop whose wifi connection died via Linux update + an EOL kernel 5.13 (ie Manjaro - rolling back to the 5.10 extended support didn't work and now no way to recconect it to correctly install the 5.15 kernel). Feel free to post any solutions.

Next, I'm trying Sparky on bare metal. I had it briefly on a decade-old 32 bit Windows 7 tablet for ~1 day (but it died shortly after the first software update). I threw out the tablet about a week later, RIP 32bit.


Git should already be there.  ???
Also check: issues tab. May help.
Always wanting to help. +100%


The solution to compiling this Calindori Pinephone app (btw, there is also an Android apk version that exists for it as well) for desktop linux use is (poorly) posted here:

Sorry, it took so long to post this as the solution was discovered shortly after posting this issue. I am new to linux.


The end result:

This worked, thanks! I only had to download some extra packages to get the file "KF5Notifications" which was missing. The program 'calindori' so far seems to execute just fine. I'm sure this would work on Ubuntu, as I am using Debian based Sparky7 Kde at the moment. I hosed my Ubuntu yesterday by downloading and deleting too many packages. –
New to Linux
 Dec 20, 2021 at 0:14

Lesson learned: always make sure you have ALL your dependencies pre-installed beforehand!

I use XFCE now btw, KDE changes too rapidly for my taste, I prefer a stable desktop.

View the most recent posts on the forum