Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

big update and goodbye xorg...

Started by carlo, September 03, 2021, 03:38:50 PM

Previous topic - Next topic

carlo

hiya
it was a while i didn't upgrade my sparky, so i decided to go for it:
the upgrading ended up with nvidia drivers giving some error with sparky kernel
so after the reboot i could just see a blinking underscore, but luckily i could work by terminal by pressing ctrl-alt-fn
i tried to uninstall nvidia and let nouvaeu do the trick, but outcome was a bit better: xorg started, though it was rather slow, and above all it froze...

as i tried to sort this out i purged the sparky kernel, did some other things and been wasting a whole morning installing and uninstalling nvidia
now nvidia drivers work as above (underscore...) while nouveau let me work at a bigger resolution but xorg won't start as well...
nouveau gives these error soon after a successful login
nouveau 0000.01.0... msvld unable to load firmware data
nouveau 0000.01.... msvld: init failed -19

nvidia seems to have issues with a daemon, but some forumes report that's quite a normal error message


is there any way i can have the graphic server on?

carlo

Little update:
i removed nvidia
then by desperation had a look into /etc/X11/xorg.conf
there device driver was still nvidia
i have replaced it with nouveau and graphic server is working now
though nouveau sucks....
any idea on how to install nvidia?

paxmark1

Which branch of Sparky?   Inxi output of your graphic card also. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

carlo

Sparky Testing

$ sudo nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106 [GeForce GTX 650 Ti] [10de:11c6] (rev a1)

Checking card:  NVIDIA Corporation GK106 [GeForce GTX 650 Ti] (rev a1)
Your card is supported by all driver versions.
Your card is also supported by the Tesla 470 drivers series.
Your card is also supported by the Tesla 460 drivers series.
Your card is also supported by the Tesla 450 drivers series.
Your card is also supported by the Tesla 418 drivers series.
It is recommended to install the
    nvidia-driver
package.

manyroads

If you haven't checked, you might find something of value here:

https://wiki.debian.org/NvidiaGraphicsDrivers
openbox, dwm & i3wm ~Reg. Linux User #449130

carlo

well.. i haven't read it in a while
however now if i install from synaptic/apt-get installation seems to run smoothly
when i tried to run sh nvidia.sh it told me there was still some nvidia driver in the kernel and that installation could not go forth...
i might try next days to run nvidia exec file and check whether anything has changed, today sure not cause i'm overwhelmed by work

View the most recent posts on the forum