Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

(SOLVED) Menu not displayed....

Started by tenfoot, August 28, 2021, 04:38:13 AM

Previous topic - Next topic


Good afternoon from New Zealand

I am returning to Sparky Linux after an absence of some time, trying out various other distributions not based on Debian. I successfully installed Sparky Linux v6.0 on my Lenovo Thinkpad T450s, without any problems.  The laptop is connected to a dock and I have an AOC 26.4" monitor connected.

The laptop has been configured to display only the AOC monitor when fully booted and therein lies my problem, as the panel displaying the menu is not shown, even though when setting things up I ensured that the native resolution of 1980 x 1280 was shown.  If I  disconnect from the dock and just use the laptop video card, everything is as it should be.

So, the question is.  What may have gone wrong and, more importantly, how may I correct it, please?

Dogs laugh, but they laugh with their tails.


If you boot the laptop, then use the monitor/display tool to use the AOC does it work as expected and shift the whole desktop to the AOC?


Thank you for your speedy response.

On installation the AOC monitor was connected. The display on the laptop was the correct resolution and showed two options - Laptop and AOC,  Both showed a resolution of 1980 x 1280. I then configured them to show Laptop = Off and AOC = ON and rebooted. While the Laptop initially displayed an image, it then went blank and the display appeared, but without the panel.
Dogs laugh, but they laugh with their tails.


It sounds like the AOC is not showing the whole of the desktop - it has possibly defaulted to 1024x768 or something like that.

If you srat up and get to the screen you get on the AOC, can you then right click and go to Applications>Settings>Display? It should then allow you to adjust the resolution and get a working desktop.

If that works then just log off and log back on and see how it behaves.

Worst case scenario is that you may need a custom xorg.conf file - but that's no biggy. However I have used an AOC in the past and it was fine.

Oh - is this connected via HDMI or VGA cable?


Thank you for your prompt response.

Unfortunately, right clicking on the does not show the Applications menu.

However, my brain woke up and I

(a) Created a keyboard shortcut (Mode4+J) to open the Mate Control Centre and then closed the computer down.

(b) Rebooted and pressed Mode4+J and the Control Centre appeared on the AOC Monitor.

(c) Opened the Display settings which showed a resolution of 1920 x 1280 I chose another resolution and then chose 1920 x 1280 again.

(d) Rebooted and the AOC monitor displayed correctly and problem appeared to be solved.

(e) Closed the lid of the laptop and the AOC display disappeared.. 

(f) Open the lid of the laptop and sometimes the AOC monitor displays but at other times I have to press the laptop On get it to do so.

So, my question now is "What have i done to create this new problem and is there a solution to it, please?

Edited at 13:00 NZT.  I feel a tad foolish as the answer was obvious when I thought about it.  It was just a matter of going to the Control Centre-Power Management-on AC Power-Display  and setting.

Now to set Sparky up as I have Linux Mint.  Hopefully, as Sparky is Debian bases, programmes like Artha, Variety ecc., will be availabe.

Dogs laugh, but they laugh with their tails.


Well done - didn't realise you were using MATE!

View the most recent posts on the forum