Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: Sparky Dist Upgrade script from 6 to 7 <SOLVED>  (Read 880 times)

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Sparky Dist Upgrade script from 6 to 7 <SOLVED>
« on: August 22, 2021, 09:36:58 pm »
I have upgraded Sparky 6 to 7 using a script. It went smooth.
https://sparkylinux.org/sparky-dist-upgrade-script/

When I use command apt update I see a mark "Stary" (Old in Polish) next to my repository list . Is it a problem?

Code: [Select]
root@Sparky:/home/rektal# apt update
Stary:1 https://repo.sparkylinux.org unstable InRelease
Stary:2 http://security.debian.org/debian-security bookworm-security/updates InRelease                   
Stary:3 https://repo.sparkylinux.org core InRelease                                                       
Stary:4 https://repo.sparkylinux.org orion InRelease                                                     
Stary:5 http://deb.debian.org/debian bookworm InRelease                                                   
Stary:6 http://deb-multimedia.org bookworm InRelease                                                     
Stary:7 http://dl.google.com/linux/chrome/deb stable InRelease                                           
Stary:8 https://apt.syncthing.net syncthing InRelease                                                     
Stary:9 https://repo.protonvpn.com/debian stable InRelease                                               
Pobieranie:10 https://mega.nz/linux/MEGAsync/Debian_10.0 ./ InRelease [2 461 B]         
Stary:11 https://repo.skype.com/deb stable InRelease

I have unchecked Debian sid repository too. Is it correct?
« Last Edit: August 26, 2021, 07:27:54 am by rektal »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2278
  • Karma: 6
    • SparkyLinux
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #1 on: August 22, 2021, 10:27:35 pm »
Yes, its OK.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #2 on: August 23, 2021, 07:52:14 am »
I have noticed that Plasma Discover is not working properly.
There is an info: KDE Discover: Unable to load applications. Please verify Internet connectivity.



Offline 21grams

  • Newbie
  • *
  • Posts: 34
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #3 on: August 23, 2021, 08:36:47 am »
I have noticed that Plasma Discover is not working properly.
There is an info: KDE Discover: Unable to load applications. Please verify Internet connectivi
There was an issue prior to 5.21.2 (as in 5.20.5) where certain elements failed to gather information ( continuous indicator rotation).
Changing repos to testing, the update to kde(5.21.2) is indeed an issue.
No problem using synaptic or Sparky Aptus.
« Last Edit: August 23, 2021, 08:53:07 am by 21grams »
21grams >> light in flight

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #4 on: August 23, 2021, 11:17:05 am »
I have a problem with exim4 and I don't know if it is associated with this upgrade.
When I restart system I see a message on black screen: Failed to start LSB :exim Mail Transport Agent.

Code: [Select]
rektal@Sparky:~$ systemctl status exim4.service
● exim4.service - LSB: exim Mail Transport Agent
     Loaded: loaded (/etc/init.d/exim4; generated)
     Active: failed (Result: exit-code) since Mon 2021-08-23 11:04:00 CEST; 4min 7s ago
       Docs: man:systemd-sysv-generator(8)
    Process: 719 ExecStart=/etc/init.d/exim4 start (code=exited, status=1/FAILURE)
        CPU: 185ms

How to repair it?

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #5 on: August 23, 2021, 11:38:54 am »
Timeshift is not working anymore. It launches in live usb mode.
In Location tab I can't select the partition where my backups are.
I see this partition on Dolphin so partition is mounted.

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #6 on: August 23, 2021, 02:07:16 pm »
Timeshift is not working due KDE Plasma 5.21.2 update. I have checked it.
I have restored system from Timeshift snapshot and Timeshift works fine. After update KDE Plasma to 5.21.2, Timeshift is only in live usb mode.
How to stop update to Plasma 5.21.2?

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #7 on: August 23, 2021, 03:57:38 pm »
I have noticed that Plasma Discover is not working properly.
There is an info: KDE Discover: Unable to load applications. Please verify Internet connectivi
There was an issue prior to 5.21.2 (as in 5.20.5) where certain elements failed to gather information ( continuous indicator rotation).
Changing repos to testing, the update to kde(5.21.2) is indeed an issue.
No problem using synaptic or Sparky Aptus.
I have checked again Debian sid repository and Discover works again.

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #8 on: August 24, 2021, 07:30:38 am »
Will there be another KDE Plasma update? Now it's KDE Plasma 5.21.5.
I think there is a dependency missing that Timeshift is no longer working.
Without Timeshift, I cannot back up my system.
Sometimes I used Timeshift to restore the system and this application is indispensable to me.

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #9 on: August 24, 2021, 09:21:23 am »
I wanted to try Systemback instead of Timeshift but it didn't work for me.
The Systemback not let me select storage directory. Default is set to /home.
I wanted to set up another location with ext4 file system but I coudn't do it. There is a red X mark.

Offline rektal

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 0
Re: Sparky Dist Upgrade script from 6 to 7
« Reply #10 on: August 26, 2021, 07:27:29 am »
After today's update of Timeshift the problem has solved. Timeshift works again.