Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: <solved>I would like to know the simple way to get newer kernel on Sparky stable  (Read 597 times)

Offline kanliot

  • Jr. Member
  • **
  • Posts: 88
  • Karma: 0
I'm running SparkyLinux 5 Stable
Code: [Select]
SparkyLinux 5.15 (Nibiru)
The kernel version here is 5.1.16.   

I'm having some odd problems with memory use from the kernel.   
Code: [Select]
grep Slab /proc/meminfo  Seems to keep growing and growing. :(

I'd like to get a kernel current for this month.   

I am a sparkylinux donator, and I'm not sure what a simple way to do this, as I'm not on the rolling release.

Thank you in advance!
« Last Edit: August 14, 2021, 08:09:12 am by kanliot »

Offline kanliot

  • Jr. Member
  • **
  • Posts: 88
  • Karma: 0
OK, basically I want to move from a kernel which is less maintained, to a kernel which is more maintained.

Do the people on this forum recommend that I try to install a kernel from debian sources?   

Or should I move from sparky-stable to  sparky-rolling?

Thanks in advance.

Offline nemomen

  • Jr. Member
  • **
  • Posts: 53
  • Karma: 0
Hello,
I am a Sparky user as Kernel: 4.19.0-17-amd64 x86_64; SparkyLinux 5.15 Nibiru sid stable Xfce 64-bit GPT PT.
I am not sure I would be your solution provider, but perhaps I could furnish you with useful information.
I always use the following commands, when update my system: … sudo update-grub && sudo update-grub2. The above-mentioned Kernel version is the present updated one. These commands work well for years at me.
Brgds
nemomen
* I noted your Kernel version is higher, I should like to supply you with information only.

Offline kanliot

  • Jr. Member
  • **
  • Posts: 88
  • Karma: 0
nemomen
* I noted your Kernel version is higher, I should like to supply you with information only.

ok that is helpful. Thank you.
(through synaptic) I uninstalled the `linux-image-sparky-amd64` metapackage, since that wasn't helping me anymore, after installing `linux-image-5.10.0-0.bpo.3-amd64` from debian (buster-backports) , which seems to be current. I also had the choice to install 4.19.

Everything is fine and easy.  Not sure why I was on `5.1`

anyhow sparkylinux gives me no surprises and that's why I like it. 

Thank you.