Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

SOLVED Trying KDE rolling

Started by BaukeP, April 09, 2021, 03:36:43 PM

Previous topic - Next topic


I downloaded the newest KDE iso (rolling) and installed it on a Dell XPS-15. Everything went fine, but when I tried to open kate as root, i got the following screen:

bauke@xps-sparky-kde:~$ pkexec kate
qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.


I installed the following packages:
wayland-protocols (1.20-1)
wdisplays (1.0-2)
qml-module-qtwayland-client-texturesharing (5.15.2-2)
qml-module-qtwayland-compositor (5.15.2-2)

But that didn't help

What should I do?

Thanks in advance



You can not run all apps with pkexec, only those ones which are configured with pkexec.

Try sudo:
sudo kate
or spsudo (if sparky-su is installed):
spsudo kate
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


And for some of the latest on the state of KDE in Sparky-Rolling, and Sid,  via Debian Planet.

Norbert has never steered me wrong with other binaries he the ball rolling in Debian.  (Calbiber and Sigil).   
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Sorry for this late reaction.
Thanks a lot. Running perfectly now!


View the most recent posts on the forum