Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: Setting up a Network Connection on 1st run  (Read 205 times)

Offline GBano

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Setting up a Network Connection on 1st run
« on: April 12, 2021, 08:41:06 pm »
Hello,

I'm new to Sparky, came over from years of Mint, Mandriva, Ubuntu...
This is an old machine, Presario 4000.

On 1st run after te installation (5.14, LXQT), I wanted to do the obligatory update/upgrade run.
But I cannot connect it to my WiFi.
I can get the Network Manager symbols into the bottom right corner but it won't open!
No netwoek settings can be found in the context menu either.
So
Code: [Select]
systemctl status NetworkManager returns "active (running)" (sorry, can't copy & paste all of it...)
Am I missing something?

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 835
  • Karma: 4
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: Setting up a Network Connection on 1st run
« Reply #1 on: April 12, 2021, 11:22:00 pm »
Standard default network management in LXQT is connman,  connmanctl  and the gui is CMST.   

You do always have the option to go with nm.   

You can try to go to Preferences >>  LXQT Settings >>  and towards the bottom is   Conmann UI Setup   Should populate a little wifi signal icon on your panel

I have 0.14.1 version of LXQT.   

Code: [Select]
systemctl status NetworkManager.service
Unit NetworkManager.service could not be found.

systemctl status connman.service
● connman.service - Connection service
   Loaded: loaded (/lib/systemd/system/connman.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2021-04-12 15:21:38 CDT; 59min ago
 Main PID: 778 (connmand)
    Tasks: 1 (limit: 4915)
   Memory: 4.9M
   CGroup: /system.slice/connman.service
           └─778 /usr/sbin/connmand -n


Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline GBano

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
Re: Setting up a Network Connection on 1st run [SOLVED]
« Reply #2 on: April 16, 2021, 04:56:38 pm »
systemctl status connman.service
Code: [Select]
systemctl status connman.service

...returns: Could not be found.
However, I adjusted the symbols in the bottom right corner last time and on re-start (!) it had nm in it, so could select and connect to a network.
Strange, but thx for the hints!

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2202
  • Karma: 4
    • SparkyLinux
Re: Setting up a Network Connection on 1st run
« Reply #3 on: April 16, 2021, 05:55:07 pm »
Sparky LXQt is shipped with network-manager as default.
Sparky LXQt 4 & 5 features network-manager-gnome, Sparky LXQt 6 has nm-tray.
Means no connman preinstalled.

What is your Wifi device?
Show:
Code: [Select]
lspci
lsusb
« Last Edit: April 16, 2021, 05:57:22 pm by pavroo »
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net