Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: HP LaserJet 1018 firmware. <Closed>  (Read 389 times)

Offline nemomen

  • Jr. Member
  • **
  • Posts: 53
  • Karma: 0
HP LaserJet 1018 firmware. <Closed>
« on: April 03, 2021, 04:41:00 pm »
Hello,
perhaps it would be interested to anyone else, too.
The HP LaserJet 1018 (and some others like LJ 1020) are always special, thus the pre-installed driver received by the distros never worked. No problem, just a command su getweb 1018 and everything works well. Until now.
BUT (1) during the last days this solution is not led to the downloading of the firmware, page not found (without the 404). The HP website is not worked, too. The Openprinting site the same.
BUT (2) when download and install the HPLIP drivers and skip the authentication request during the install process, the firmware has been downloaded and the printer works.
About the authentication process (partial information) : Checking for network connection...
Downloading plug-in from:
warning: sparky distro is not found in AUTH_TYPES and than must to skip for downloading.
Does anyone think it would be necessary to take any steps for this verification, please.
Do never worry, be always happy!
nemomen
P.S.
Additional information to point (1): I'm gonna closed this topic, thus it seems the previously possible way by using getweb command remains unchanged (has not been available) and the hp-setup followed by hp-plugin commands work. Be careful, the HP suggests not to run the programs as root, however their software does not enable any other, than using the root!
Additional information to point (2): SparkyLinux distro authentication does not work at HP, it has to be skipped for result.
Care safe for all the Sparkers.
nemomen
« Last Edit: May 19, 2021, 01:58:38 pm by nemomen »