Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

SOLVED: premission problem

Started by klein5366, April 02, 2021, 05:12:56 AM

Previous topic - Next topic


i tried installing multisystem on nibiru 5.14 x86_64
i added the ppa's key
i added the ppa
it installed fine with no errors
but when i trying to run it:
    from menu > accessories > multisystem i get error:USER:klein is not admin
    from terminal sudo /usr/local/bin/multisystem, type in my password and i get error:not root!, nohup:appending output to 'nohup.out'
    from terminal cd /usr/local/bin
                    sudo ./multisystem, error: not root! and never asks for password, nohup:appending output to 'nohup.out'

when i have used multisystem in ubuntu, it starts without user being root, it only asks for user password when adding or deleting an iso

is there any way to make this work in sparky ?

nohup.out file
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /root/.gvfs
      Output information may be incomplete.
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]



Sudo, after successfully validating your password, won't be asking for it for a few minutes, that's why you sometimes get the password prompt and sometimes not. Basically it shows after first usage since boot or after a few minutes of the command not being used. What needs to be answered is what version of this package were you using on Ubuntu and what version are you using now.

I've looked at the scripts (version 1.0454) for this and the first thing it checks is actually if you're root. That's the funny thing: it bails out with "Error: not root" when you actually are root (user id equal to 0, which means root - reversed logic). Try running it the terminal without sudo and see if it works for you.
There's no such thing as "impossible". :)


i ran:
cd /usr/local/bin <enter>
./multisystem <enter>

Gtkdialog version: 0.8.3
LANGSEL:English|en|en_US.UTF-8|Ryan J Nicholson|

(gtkdialog:5064): Gtk-WARNING **: 11:56:33.800: Unable to locate theme engine in module_path: "murrine",

dialog box pops up (error: USER:klein is not admin!)

nohup: appending output to '/home/klein/nohup.out'

sudo apt-get install murrine
E: Unable to locate package murrine

for something else i went through installing murrine package but i don't remember how i did it .


sudo apt update
sudo apt install gtk2-engines-murrine
Quote from: forum rulesWhen an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at [url="//"][/url]


"Murrine" refers to the GTK engine of the same name. In Debian it's the "gtk2-engines-murrine" package:
That's not an issue though, as GTK will fall back to another engine.

The issue here (after some more script analysis) seems to be that your user is not a part of the "adm" group. The message on this could be a bit clearer. Anyways, add yourself to the "adm' group:
sudo gpasswd -a klein adm

I assume your user name is "klein" as per the error message you pasted earlier (if it's not, replace it with your user name). After this you'll need to logout and log back in for the changes to take effect. Try running the app once again (without sudo of course).
There's no such thing as "impossible". :)


thank you MoroS and lami07
both solutions worked great 

View the most recent posts on the forum