Installation & Upgrade > System upgrading

Dependency itch

(1/5) > >>

igemxrozb:
HI I am completely new to Unix systems. I Saw that there is a beta driver for Intel HD graphics 4400 of vulkan for higher demanding games, that must mean that it only needs a driver not a support within hardware really. So i thought that i can install vulkan on my Sparky also having i5 4th generation processor.
Could you please also help me get all dependencies and repositories? Because I cannot install many debian files because many installations say "Dependency is not satisfiable" and I'd really hate to bypass that

Currently I See my computer has healed and give thanks as you are quite the least demanding on hardware if not most Unix operating system package. Running very smoothly. Cannot be compared to windows which requires antivirus all the time aside sophos maybe.

pavroo:
1. What Sparky version / editions you have?
2. Try to refresh package list:

--- Code: ---sudo apt update
--- End code ---
3. What package you can not install? Show an output of broken installation:

--- Code: ---sudo apt install package-name
--- End code ---
4.Did you add any 3rd party repositories?

igemxrozb:
SparkyLinux version 6 Po-Tolo if that's enough information, thanks.
Can I Get software center separately? Because Sparky is using Aptus AppCenter
When I refreshed it said I can upgrade 17 packages which I had most likely manually installed after updates.
May have added third party repositories

Trying to install COMODO For linux debian package
 cav-linux : Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable

E: Unable to correct problems, you have held broken packages.
I already installed libssl1.0.0 and other but am unable to locate libssl 0.9.8 it says that libssl version 0.9.8 is referred to as different program "Package libssl0.9.8 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source"
So perhaps the COMODO linux is outdated over all?

Also installing tar.gz file does not work which is a sound converter, the ./configure command within its directory says "no such path or directory" and skipping configure command make install command gives out different error which is
sudo make
git log 3fd8.. --pretty --numstat --summary | git2cl > ChangeLog
fatal: not a git repository (or any of the parent directories): .git
cat ChangeLog.old >> ChangeLog
cat: ChangeLog.old: No such file or directory
make: *** [makefile:9: changelog] Error 1
Anyway the ./configure command gives out no path before doing sudo make install on tar.gz

Also trying to install Vulkan and DVTX or what was it called for League of Legends if you can help me with that.

I was wondering if there is a package to install all repositories and dependencies. Some other cool stuff you could note out for me to do. I know that Sparky uses 256MB of RAM or so, definitely staying with sparky

[Modified] And if you could show me how to run Microsoft Office OneNote? PlayOnLInux didn't work out, but I got word, excel, powerpoint installed.
Really enjoy drawing and writing in oneNote is there a linux software to draw and write in? Best system and portable drive encryption software? You could move this thread to general if you like or miscalinous

pavroo:
There is no Software Center in Debian and Sparky repos, but you can use Synaptic which is already installed.


--- Quote ---cav-linux : Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable
--- End quote ---
It means you can not install it on any version of Sparky - the dependency version is too old to be installed.
To fix it run:

--- Code: ---sudo apt install -f
--- End code ---

Compiling packages from source is not recommended for new Linux users.
Mayby a package you need is in Debian or Sparky repos, just check:

--- Code: ---sudo apt policy package-name
--- End code ---

igemxrozb:
Is there a way to see all packages in GUI or list the available packages with description? That's why I Thought of software center. Even with -F command it failed, guess its so outdated that I do not need any anti malware for new Linux, if this was Ubuntu then I'd definitely know I do not need antivirus.
Shows this with -f "Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming." and again "cav-linux : Depends: libssl0.9.8 (>= 0.9.8m-1) but it is not installable"

Still cannot get tar.gz files to install, thanks.

Navigation

[0] Message Index

[#] Next page

Go to full version