Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: [SOLVED] Suspend is not working  (Read 1581 times)

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #15 on: March 20, 2021, 06:32:42 am »
OK. I will try.

This is the output of this command in Tumbleweed:
Code: [Select]
[    3.901483] fb0: switching to nouveaufb from VESA VGA
[    3.902082] nouveau 0000:01:00.0: vgaarb: deactivate vga console
[    3.902175] nouveau 0000:01:00.0: NVIDIA G94 (094100a1)
[    4.045166] nouveau 0000:01:00.0: bios: version 62.94.11.00.03
[    4.065511] nouveau 0000:01:00.0: fb: 512 MiB GDDR3
[    4.134439] nouveau 0000:01:00.0: DRM: VRAM: 512 MiB
[    4.134441] nouveau 0000:01:00.0: DRM: GART: 1048576 MiB
[    4.134444] nouveau 0000:01:00.0: DRM: TMDS table version 2.0
[    4.134447] nouveau 0000:01:00.0: DRM: DCB version 4.0
[    4.134449] nouveau 0000:01:00.0: DRM: DCB outp 00: 02000300 00000028
[    4.134451] nouveau 0000:01:00.0: DRM: DCB outp 01: 01000302 00020030
[    4.134453] nouveau 0000:01:00.0: DRM: DCB outp 02: 04011310 00000028
[    4.134455] nouveau 0000:01:00.0: DRM: DCB outp 03: 02011312 00020030
[    4.134457] nouveau 0000:01:00.0: DRM: DCB outp 04: 010223f1 00c0c080
[    4.134460] nouveau 0000:01:00.0: DRM: DCB conn 00: 00001030
[    4.134462] nouveau 0000:01:00.0: DRM: DCB conn 01: 00002130
[    4.134463] nouveau 0000:01:00.0: DRM: DCB conn 02: 00000210
[    4.134465] nouveau 0000:01:00.0: DRM: DCB conn 03: 00000211
[    4.134467] nouveau 0000:01:00.0: DRM: DCB conn 04: 00000213
[    4.136029] nouveau 0000:01:00.0: DRM: MM: using CRYPT for buffer copies
[    4.136600] nouveau 0000:01:00.0: DRM: failed to create encoder 0/1/0: -19
[    4.136603] nouveau 0000:01:00.0: DRM: TV-1 has no encoders, removing
[    4.427268] nouveau 0000:01:00.0: DRM: allocated 1920x1080 fb: 0x70000, bo 00000000c884864e
[    4.428227] fbcon: nouveaudrmfb (fb0) is primary device
[    4.519972] nouveau 0000:01:00.0: [drm] fb0: nouveaudrmfb frame buffer device
[    4.554720] [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0 on minor 0

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #16 on: March 20, 2021, 07:32:01 am »
This is the output in Sparky
Code: [Select]
[    2.350783] nouveau 0000:01:00.0: vgaarb: deactivate vga console
[    2.351595] nouveau 0000:01:00.0: NVIDIA G94 (094100a1)
[    2.464813] nouveau 0000:01:00.0: bios: version 62.94.11.00.03
[    2.485105] nouveau 0000:01:00.0: fb: 512 MiB GDDR3
[    2.553568] nouveau 0000:01:00.0: DRM: VRAM: 512 MiB
[    2.553570] nouveau 0000:01:00.0: DRM: GART: 1048576 MiB
[    2.553572] nouveau 0000:01:00.0: DRM: TMDS table version 2.0
[    2.553573] nouveau 0000:01:00.0: DRM: DCB version 4.0
[    2.553575] nouveau 0000:01:00.0: DRM: DCB outp 00: 02000300 00000028
[    2.553577] nouveau 0000:01:00.0: DRM: DCB outp 01: 01000302 00020030
[    2.553579] nouveau 0000:01:00.0: DRM: DCB outp 02: 04011310 00000028
[    2.553580] nouveau 0000:01:00.0: DRM: DCB outp 03: 02011312 00020030
[    2.553581] nouveau 0000:01:00.0: DRM: DCB outp 04: 010223f1 00c0c080
[    2.553583] nouveau 0000:01:00.0: DRM: DCB conn 00: 00001030
[    2.553584] nouveau 0000:01:00.0: DRM: DCB conn 01: 00002130
[    2.553586] nouveau 0000:01:00.0: DRM: DCB conn 02: 00000210
[    2.553587] nouveau 0000:01:00.0: DRM: DCB conn 03: 00000211
[    2.553588] nouveau 0000:01:00.0: DRM: DCB conn 04: 00000213
[    2.555184] nouveau 0000:01:00.0: DRM: MM: using CRYPT for buffer copies
[    2.555770] nouveau 0000:01:00.0: DRM: failed to create encoder 0/1/0: -19
[    2.555772] nouveau 0000:01:00.0: DRM: TV-1 has no encoders, removing
[    2.846347] nouveau 0000:01:00.0: DRM: allocated 1920x1080 fb: 0x70000, bo (____ptrval____)
[    2.847209] fbcon: nouveaudrmfb (fb0) is primary device
[    2.940198] nouveau 0000:01:00.0: [drm] fb0: nouveaudrmfb frame buffer device
[    2.974789] [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0 on minor 0
[  109.950686] nouveau 0000:01:00.0: firmware: direct-loading firmware nouveau/nv84_xuc00f
[  109.997952] nouveau 0000:01:00.0: firmware: direct-loading firmware nouveau/nv84_xuc103


There are no errors.

But unfortunately it didn't help with suspending. Screen went off, but only the fans keep running.[/code]
« Last Edit: March 20, 2021, 09:47:33 am by rektal »

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 290
  • Karma: 0
  • Problem solver ;)
Re: Suspend is not working
« Reply #17 on: March 20, 2021, 10:29:04 am »
Ok, so it wasn't the lack of firmware (although the card should behave a bit better now).

One other thing we might try is adding the ACPI daemon to handle events:
Code: [Select]
sudo apt install acpid acpi-support
sudo systemctl status acpid

The last command should show acpid enabled and running. If not, then you need to do it manually:
Code: [Select]
sudo systemctl enable acpid
sudo systemctl start acpid

After that try suspending again.
There's no such thing as "impossible". :)

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #18 on: March 20, 2021, 11:40:07 am »
systemctl status acpid gives me this
Code: [Select]
● acpid.service - ACPI event daemon
     Loaded: loaded (/lib/systemd/system/acpid.service; disabled; vendor pr>
     Active: active (running) since Sat 2021-03-20 11:34:40 CET; 2min 37s a>
TriggeredBy: ● acpid.path
             ● acpid.socket
       Docs: man:acpid(8)
   Main PID: 491 (acpid)
      Tasks: 1 (limit: 9459)
     Memory: 528.0K
        CPU: 6ms
     CGroup: /system.slice/acpid.service
             └─491 /usr/sbin/acpid

Warning: some journal files were not opened due to insufficient permissions.
ACPI deamon is enabled and running.

I tried to suspend but with no result. Screen went off, but only the fans keep running.

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #19 on: March 20, 2021, 12:16:44 pm »
When I was searching in the internet I have found this:
https://www.linuxquestions.org/questions/suse-opensuse-60/suspend-not-working-4175614923/
https://forums.opensuse.org/showthread.php/534882-Hibernate-and-suspend-not-working
https://bugzilla.redhat.com/show_bug.cgi?id=832679

Maybe it is kernel related.
On Tumbleweed I have 5.11.6 kernel and suspend is working.
MX LInux 19.3 has 5.8 kernel and suspend is working. This kernel is older than Sparky's kernel. They are Debian based distros.


Offline MoroS

  • Sr. Member
  • ****
  • Posts: 290
  • Karma: 0
  • Problem solver ;)
Re: Suspend is not working
« Reply #20 on: March 20, 2021, 03:18:25 pm »
It might me something in Debian Testing, which Sparky is based on. The default kernel in Sparky is that of Debian Testing (unless you're using stable). It's a bit hard to say, but I'm running out of ideas over here.

You might try using another kernel like Liquorix: https://wiki.sparkylinux.org/doku.php/how_to_install_longterm_liquorix_kernels

It's nicely optimized, for certain cases better than the stock Debian kernel.
You can install other kernels with APTus (as described in the link above at the bottom of the page).
There's no such thing as "impossible". :)

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #21 on: March 20, 2021, 05:07:27 pm »
Thank you for your help.
I installed newer kernel from default repo and it is 5.11.8-1 but it is no active.
Active kernel is still 5.10.0-4. How to change it?

This is inxi -br output:
Code: [Select]
System:
  Host: Sparky Kernel: 5.10.0-4-amd64 x86_64 bits: 64
  Desktop: KDE Plasma 5.20.5 Distro: SparkyLinux 6 (Po-Tolo)
Machine:
  Type: Desktop Mobo: Gigabyte model: EP45-DS3
  serial: <superuser required> BIOS: Award v: F10b date: 09/03/2009
CPU:
  Info: Dual Core Intel Core2 Duo E8400 [MCP] speed: 2000 MHz
  min/max: 2000/2667 MHz
Graphics:
  Device-1: NVIDIA G94 [GeForce 9600 GT] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: NV94 v: 3.3 Mesa 20.3.4
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
Drives:
  Local Storage: total: 2.27 TiB used: 826.26 GiB (35.5%)
Repos:
  Active apt repos in: /etc/apt/sources.list
  1: deb http://deb.debian.org/debian/ bullseye main contrib non-free
  2: deb-src http://deb.debian.org/debian/ bullseye main contrib non-free
  3: deb http://security.debian.org/ bullseye-security/updates main contrib non-free
  4: deb-src http://security.debian.org/ bullseye-security/updates main contrib non-free
  5: deb http://deb-multimedia.org/ bullseye main non-free
  No active apt repos in: /etc/apt/sources.list.d/dropbox.list
  No active apt repos in: /etc/apt/sources.list.d/google.list
  No active apt repos in: /etc/apt/sources.list.d/liquorix.list
  No active apt repos in: /etc/apt/sources.list.d/pipelight.list
  No active apt repos in: /etc/apt/sources.list.d/playonlinux.list
  Active apt repos in: /etc/apt/sources.list.d/sid.list
  1: deb http://ftp.debian.org/debian/ sid non-free contrib main
  2: deb-src http://ftp.debian.org/debian/ sid non-free contrib main
  3: deb http://www.deb-multimedia.org/ sid non-free main
  Active apt repos in: /etc/apt/sources.list.d/sparky-unstable.list
  1: deb https://repo.sparkylinux.org/ unstable main
  2: deb-src https://repo.sparkylinux.org/ unstable main
  Active apt repos in: /etc/apt/sources.list.d/sparky.list
  1: deb https://repo.sparkylinux.org/ core main
  2: deb-src https://repo.sparkylinux.org/ core main
  3: deb https://repo.sparkylinux.org/ potolo main
  4: deb-src https://repo.sparkylinux.org/ potolo main
  No active apt repos in: /etc/apt/sources.list.d/virtualbox.list
  No active apt repos in: /etc/apt/sources.list.d/wine-staging.list
Info:
  Processes: 179 Uptime: 3m Memory: 7.77 GiB used: 1.52 GiB (19.6%)
  Shell: Bash inxi: 3.3.01

When I want to remove old kernel by APTus it shows me to remove 5.11.8-sparky-amd64. Active kernel is 5.10.0-4-amd64.
And I do not see the newest kernel in bootloader.
« Last Edit: March 20, 2021, 05:10:23 pm by rektal »

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 290
  • Karma: 0
  • Problem solver ;)
Re: Suspend is not working
« Reply #22 on: March 20, 2021, 05:37:55 pm »
You can verify if the kernel is installed by running:
Code: [Select]
ls /boot/vmlinuz* -lThis should show you all installed kernels.

If the one you want is there, try updating your GRUB config and rebooting:
Code: [Select]
sudo update-grub2
It'll output all the kernels that are added. If the one you want is not first in the list, then it won't boot as default (the first one is the default, but you'll find others in the advanced options in the GRUB menu while booting).
There's no such thing as "impossible". :)

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #23 on: March 20, 2021, 05:46:58 pm »
ls /boot/vmlinuz* -l output:
Code: [Select]
-rw-r--r-- 1 root root 6809024 03-02 17:49 /boot/vmlinuz-5.10.0-4-amd64
-rw-r--r-- 1 root root 5389376 03-20 13:02 /boot/vmlinuz-5.11.8-sparky-amd64
I could not update grub
Code: [Select]
[sudo: update-grub2: command not found
Should I install grub2?

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 290
  • Karma: 0
  • Problem solver ;)
Re: Suspend is not working
« Reply #24 on: March 20, 2021, 05:56:14 pm »
No, for the time being don't. Let's test is this works first.

When rebooting, when in GRUB you'll have the option of choosing "Advanced options for Sparky GNU/Linux". This will display a menu with other available kernels to boot. Try selecting the new kernel from there first and see if your system will suspend while running it.
There's no such thing as "impossible". :)

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #25 on: March 20, 2021, 05:59:01 pm »
I am very pleased with Sparky and I think it will be my default distro in the future. It is stable for me and updates go smooth.
A lack of suspend feature is only a little inconvenience.

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #26 on: March 20, 2021, 06:08:33 pm »
I chose Advanced options for Sparky GNU/Linux but it is only one kernel 5.10.0-4-amd64.

In APTus there are options: Install Debian kernel or Install Sparky kernel. Maybe this are another sort of kernels?

In Synaptic i have installed packages like:Sparky GRUB Theme, GRUB Legacy , grub-common.
I think that default is installed older version of grub not grub2 on Sparky.

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #27 on: March 20, 2021, 06:17:27 pm »
I did sudo update-grub instead
Code: [Select]
root@Sparky:/home/rektal# sudo update-grub
Searching for GRUB installation directory ... found: /boot/grub
WARNING: tempfile is deprecated; consider using mktemp instead.
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
WARNING: tempfile is deprecated; consider using mktemp instead.
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-5.11.8-sparky-amd64
Found kernel: /boot/vmlinuz-5.10.0-4-amd64
Updating /boot/grub/menu.lst ... done
But after reboot I do not see 5.11.8 kernel in advanced settings  of bootloader.

Offline MoroS

  • Sr. Member
  • ****
  • Posts: 290
  • Karma: 0
  • Problem solver ;)
Re: Suspend is not working
« Reply #28 on: March 20, 2021, 07:19:09 pm »
That's because the advanced options only show kernels that don't boot by default. From the "update-grub" command I saw that 5.11.8 was first on the list, so now it's the default - no need to use the advanced options to boot. :)

So, now that you're booting 5.11, did you try suspending?
There's no such thing as "impossible". :)

Offline rektal

  • Newbie
  • *
  • Posts: 38
  • Karma: 0
Re: Suspend is not working
« Reply #29 on: March 20, 2021, 08:31:15 pm »
But uname -r output is:
Code: [Select]
uname -r
5.10.0-4-amd64