Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: Shutdown beep on Xfce, but not on MATE or Openbox  (Read 789 times)

Offline pccobbler

  • Newbie
  • *
  • Posts: 46
  • Karma: 0
Shutdown beep on Xfce, but not on MATE or Openbox
« on: February 26, 2021, 12:14:28 am »
I have multiple Sparky systems: Xfce, MATE, and Openbox. Xfce beeps on shutdown, which is annoying when I'm wearing headphones. I surfed around for a solution, but they're all over the map, with Ubuntu solutions not being relevant at all, not surprising given the relationship between Debian and Ubuntu.

Why is Xfce different? Can someone recommend a solution?

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 852
  • Karma: 4
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: Shutdown beep on Xfce, but not on MATE or Openbox
« Reply #1 on: February 26, 2021, 01:07:43 am »
"Multiple Sparky Systems"   Is this multiple computers or multiple DE's on 1 computer?

  If you have multiple DE's on 1 computer the dot files ( .blah-config  _) in your ~ file  (~ == /home/yournameforhome) Some DE's will use the same name for certain items and that can cause conflicts.    If you have multiple computers, well, I do not use XFCE at present and others will have to help.   

As always, pet peeve of mine - not stating Stable versus Rolling  is something that should be done for most requests for help.   Also stating where you have searched prior to this forum if you have is helpful. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline pccobbler

  • Newbie
  • *
  • Posts: 46
  • Karma: 0
Re: Shutdown beep on Xfce, but not on MATE or Openbox
« Reply #2 on: February 26, 2021, 01:40:33 am »
Mea culpa.

The MATE is on an external SSD connected via USB. The Openbox and Xfce are on different USB flash drives (NOT LiveUSB, installed). Only one of them is connected at a time to my laptop (Intel 3rd Generation Core processor and 8 GB of memory), as I dislike multiple-boot configurations. I always remove the internal SATA Windows SSD when creating a new Linux system

The MATE is rolling, while the Openbox and Xfce are stable. I'd prefer all to be stable, but MATE is not offered that way.

I expected Openbox and Xfce to be similar in nature, as both are stable, but the former does not have the auto-update while the latter does. The Openbox does not beep on shutdown.
« Last Edit: February 26, 2021, 01:51:57 am by pccobbler »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 852
  • Karma: 4
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: Shutdown beep on Xfce, but not on MATE or Openbox
« Reply #3 on: February 26, 2021, 08:32:15 pm »
My hunch, if Openbox and XFCE are both on the same ~/ is that it probably is not a conflict.   Others who use Openbox of XFCE feel free to respond.   

Mar 04.   So it sounds like a design in XFCE.   I would suggest looking only at XFCE sites and if they have a forum post there.  Sorry to not have any other answers. 
« Last Edit: March 04, 2021, 07:53:27 pm by paxmark1 »
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline pccobbler

  • Newbie
  • *
  • Posts: 46
  • Karma: 0
Re: Shutdown beep on Xfce, but not on MATE or Openbox
« Reply #4 on: March 04, 2021, 12:12:33 am »
The two systems are on completely separate drives, so there's no sharing of files.

Offline darknet

  • Newbie
  • *
  • Posts: 9
  • Karma: 1
Re: Shutdown beep on Xfce, but not on MATE or Openbox
« Reply #5 on: March 11, 2021, 10:27:27 am »
try this:

xset b off

automaticly each time you login :
Settings >> Session & start >> Application Autostart

At the window bottom => + Add application

and fill the 3 fields like :

XBells Off
Desable sounds
xset b off