Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: sparky-aptus-upgrade thinks it is a live system - because of username? <SOLVED>  (Read 167 times)

Offline Oliver

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
I have this problem, too, and followed the instructions in topic https://forum.sparkylinux.org/index.php/topic,3519.msg7761.html#msg7761

I checked 'cat /etc/passwd | grep >divers<' and got the following:

oliver@oliver-AO751h:~$ cat /etc/passwd | grep 1000
oliver:x:1000:1000:Oliver:/home/oliver:/bin/bash
oliver@oliver-AO751h:~$ cat /etc/passwd | grep 1001
oliver@oliver-AO751h:~$ cat /etc/passwd | grep 1002
oliver@oliver-AO751h:~$ cat /etc/passwd | grep Live
oliver@oliver-AO751h:~$ cat /etc/passwd | grep live
oliver:x:1000:1000:Oliver:/home/oliver:/bin/bash


I think the problem is that my username is "oliver" and so the file passwd includes "live". Make that sense? Is that possible?

Is there in easy way to solve that or do I have to create a new user with a name without "live" in it and delete the old one?
« Last Edit: March 13, 2021, 03:06:08 pm by Oliver »

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 305
  • Karma: 6
    • Sparky Community Repos
Quote
I think the problem is that my username is "oliver" and so the file passwd includes "live". Make that sense? Is that possible?

I'm afraid you are correct. We will fix it.

For now edit (as root or with sudo) /usr/bin/sparky-aptus-upgrade and find

Code: [Select]

# if Live system just quit, don't upgrade
TESTMODE=`grep "live" /etc/passwd`
if [ "$TESTMODE" != "" ]; then
$DIALOG $TITLE"$TITLETEXT" $MSGBOX $TEXT"$LOCAL2"
exit 1
fi

Disable it by putting # in front of every line and save changes.

Code: [Select]
# if Live system just quit, don't upgrade
#TESTMODE=`grep "live" /etc/passwd`
#if [ "$TESTMODE" != "" ]; then
#        $DIALOG $TITLE"$TITLETEXT" $MSGBOX $TEXT"$LOCAL2"
#        exit 1
#fi
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline Oliver

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
 :) That was easy! Now it works properly!

Thank you very much for your help!

Oliver