Software & hardware support > Hardware

<SOLVED> Read-only USB stick.

(1/2) > >>

nemomen:
Hello Sparkers,
I have used one of my pen-drive many times without any problems.
Once I noted it had turned to a read-only status, not the folders and/or the files, but the device itself. I have no viruses according to my best knowledge, although it is always updated.
I did not find any working solutions to solve the problem under Windows, none of them worked so far.
Does anyone has any idea how could I clean the read-only attribute under Linux/SparkyLinux?
I have already tried to use the GParted with no result.
I use SparkyLinux Nibiru 5.13 Xfce 64-bit.
Thanks in advance and happier New Year for you all.
nemomen

paxmark1:
Gparted is a whole level up - that is partitioning.   "man chmod"  probably do not need  "man chown"

Command line     "ls -al"   your permissions will be at the beginning   as


--- Code: ---drwxr-xr-x 2 paxmark paxmark      4096 Dec 27 23:27  .                                                             │
drwxr-xr-x 7 paxmark paxmark     16384 Dec 27 23:27  ..                                                            │
-rw-r--r-- 1 paxmark paxmark  19933700 Nov 13  2019 'St Olaf.Choir-Ehre.sei.Gott.in.der.Höhe.mkv'                  │
-rw-r--r-- 1 paxmark paxmark 115114772 Dec 24 21:18 'St.Olaf.Choir-Night.Silence-Silent.Night- Nidarosdomens.jentek│
or.mkv'                                                                                                            │
-rw-r--r-- 1 paxmark paxmark  89418541 Feb 20  2019  St.Olaf.Christmas.Fest-2018-Wake.Awake.For.Night.Flying.mkv   │
-rw-r--r-- 1 paxmark paxmark  77434151 Dec 16 11:02 'Wartburg Christmas.Wartburg.2020-Night.Wonder.mkv'
--- End code ---

The rw-r--r--    probably what you want.   which is 644   if you want to type less

chown is how you fix it.   


--- Code ---https://www.redhat.com/sysadmin/audit-permissions-find
--- End code ---

How to search a directory and subdirectories


--- Code: --- find . -perm -644                                             
.                                                                                                     
./Wartburg Christmas.Wartburg.2020-Night.Wonder.mkv     
./St Olaf.Choir-Ehre.sei.Gott.in.der.Höhe.mkv                       
./St.Olaf.Christmas.Fest-2018-Wake.Awake.For.Night.Flying.mkv 
./St.Olaf.Choir-Night.Silence-Silent.Night- Nidarosdomens.jentekor.mkv

--- End code ---

Read is 4   Write is 2 X (execute - do) is 1   RWX =7   programs.   RW 6   R (read only) is 4.   
You can find 444's which will not write - so no copy via

find . -perm -444

To fix directories and subdirectores search "Recusrsive chmod"

bin:
The most likely reason is that it has reached the end of its useful life.

These things are not expensive but it pays to but good quality if possible.

nemomen:
Dear Paxmark1 and bin!
Thanks for yr quick responds.
I have not used the chmod command too often, by this reason I could not be taken a master of using it, so thanks for yr suggestions. I'm gonna try it a.s.a.p.
It seems to me the device would be reached its useful life, the only problem, that is all data stored on it are very sensitive, so I do not want to destroy anyway. Luckily those data were backup yet.
Nothing are made for eternal use.
Happier New Year for you two and for all the Sparkers!
nemomen

moreno:
May I ask which USB stick are you using for the process? I'm recently using a 32gb Corsaire Voyager but I wanna buy a Kanguru because I heard they work better. I'm not sure if it matters which stick you use but one of my friends suggested me to use a different one so yesterday I have ordered one to my
--- Code ---property in Cyprus
--- End code ---
. Hope it works this time.

Navigation

[0] Message Index

[#] Next page

Go to full version