Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

youtube-dl-gui

Started by Oulik, December 11, 2020, 06:55:43 PM

Previous topic - Next topic

Oulik

Hope you can help.

I am trying to install youtube-dl-gui, but Synaptic tells me that there is no package although it is listed.

Please help.

pavroo

There is 'youtube-dlg' package instead.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

Oulik

Thank you for your reply.
First it told me to install several packages (Python version) which I did.

Then I get this message: Package youtube-dlg has no available version but exists in the database.

pavroo

You didn't say what Sparky version you have.
The 'youtube-dlg' package is available on Sparky 4 & 5 only, it hasn't been upgraded for 3 years.
I suggest to install other application, for example 'clipgrab' or 'sparky-tube'.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

paxmark1

As posted, sparky-tube would be worth a try.

Background info on general options for youtube-dl and GUI's follows.

The parent program - terminal based youtube-dl is always under heavy development.   It is very common for youtube-dl to fail with the version installed due to modifications via you-tube.   It can also start to fail for other sites that it is useful for.    When that occurs, the using "sudo youtube-dl -U" will give you the most current verison from the home page.   

https://github.com/ytdl-org

Via reading "man youtube-dl" there is a section that talks about the effort youtube-dl has done to ease python3 implementation.    A quick search and  linux options for a GUI is at (from 2020)

https://linuxpip.org/best-youtube-dl-gui/

Since the changes occur frequently, it probably better to not use the Debian binaries but to go upstream to upgrade the GUI that you choose also.   Python often uses "pip"  as a means to install and upgrade.   Synaptic, aptus and command line "apt" will not offer you programs that do not originate from you etc/apt/sources ...... repositories.  sparky-tube would be there via the Sparky repositories

in view of
https://release.debian.org/transitions/html/python2-rm.html

I would strongly recommend not  using any Python2 gui programs. 

Myself I just usually use the command line of youtube-dl.     

For getting music

youtube-dl --extract-audio --prefer-ffmpeg --audio-format m4a --audio-quality 0 --embed-thumbnail    "url"

or change m4a to mp3   

peace out.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Oulik


moreno

Quote from: Oulik on December 12, 2020, 09:27:47 AM
Thank you. Will do that.
Hello, did it work for you I wonder? I did the same thing but didn't work

View the most recent posts on the forum