Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: <SOLVED>The upgrading warning  (Read 628 times)

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
<SOLVED>The upgrading warning
« on: November 25, 2020, 12:23:46 pm »
This upgrading issue has been happened for serveral time. When linux header is getting upgraded, often, comes one or more warnings. Is there something wrong? Of the recent upgrade , the terminal says as the following:
Code: [Select]
"Setting up linux-image-5.9.11-sparky-amd64 (5.9.11-1) ...
"dkms: running auto installation service for kernel 5.9.11-sparky-amd64:.
"update-initramfs: Generating /boot/initrd.img-5.9.11-sparky-amd64
"W: Possible missing firmware /lib/firmware/i915/rkl_dmc_ver2_01.bin for module i915"
After some other normal upgrading, next is this abnormal:
Code: [Select]
"Processing triggers for desktop-file-utils (0.26-1) ...
"Processing triggers for initramfs-tools (0.139) ...
"update-initramfs: Generating /boot/initrd.img-5.9.11-sparky-amd64
"W: Possible missing firmware /lib/firmware/i915/rkl_dmc_ver2_01.bin for module i915"
Then:
Code: [Select]
"Processing triggers for initramfs-tools (0.139) ...
"update-initramfs: Generating /boot/initrd.img-5.9.11-sparky-amd64
"W: Possible missing firmware /lib/firmware/i915/rkl_dmc_ver2_01.bin for module i915"
Finally:
Code: [Select]
"shown@shown-pc:~$ Processing triggers for initramfs-tools (0.139) ...
"bash: syntax error near unexpected token `('
"shown@shown-pc:~$ update-initramfs: Generating /boot/initrd.img-5.9.11-sparky-amd64
"bash: update-initramfs:: command not found
"shown@shown-pc:~$ W: Possible missing firmware /lib/firmware/i915/rkl_dmc_ver2_01.bin for module i915
"bash: W:: command not found"

So...What do all of those mean, what should I do?




« Last Edit: January 10, 2021, 11:35:22 am by mdre808 »

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 306
  • Karma: 6
    • Sparky Community Repos
Re: The upgrading warning
« Reply #1 on: November 26, 2020, 02:07:06 pm »
https://unix.stackexchange.com/questions/618869/debian-bullseye-firmware-for-i915

TL;DR You should not bother yourself with that error.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
Re: The upgrading warning
« Reply #2 on: November 27, 2020, 02:41:15 am »
However, just ingnore it?

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 306
  • Karma: 6
    • Sparky Community Repos
Re: The upgrading warning
« Reply #3 on: November 27, 2020, 06:24:58 am »
That is correct. Just ignore it.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
Re: The upgrading warning
« Reply #4 on: November 28, 2020, 03:33:41 am »
Nice.