Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

[Solved] can't upgrade

Started by mdre808, November 14, 2020, 04:07:32 PM

Previous topic - Next topic

mdre808

Hi there, my sparky is semi-rolling 64bit, 6, po tolo. This problem confused me a long time(for months). When I want to upgrade the system, there is awalys a software that can't be upgraded——sparky6-apt. I tried to upgrade it, the terminal showed that it "Depends: libc6 (>= 2.30) but 2.28-10 is to be installed". Still, never get a complete upgrade, do I?  Second, some software such as GIMP, musescore2, qbittorrent, etc., though constantly upgrading, they always seem to stay in old version.; So because of this former problem? Because after I had tried to upgrade evince, (downloaded pacage), it prompted some depencies, and that "old friend" libc6 still included on the list. So is there something wrong? What can I do?

lami07

Run this in terminal and post the result
cat /etc/apt/sources.list
Quote from: forum rulesWhen an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at [url="//irc.freenode.net"]irc.freenode.net[/url]

pavroo

Must be a mess, show also:
cat /etc/os-release
cat /etc/apt/sources.list.d/sparky.list
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

mdre808

#3
cat /etc/apt/sources.list

deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free
deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates non-free contrib main
deb http://www.deb-multimedia.org/ buster non-free main   

##
##
##
##
##
##
##
## Other repos can be found in /etc/apt/sources.list.d directory ##


cat /etc/os-release
PRETTY_NAME="SparkyLinux 6 (Po-Tolo)"
NAME="SparkyLinux"
VERSION_ID="6"
VERSION="6 (Po-Tolo)"
ID=sparky
ID_LIKE=debian                                                                                                                       
HOME_URL="https://sparkylinux.org/"                                                                                                   
SUPPORT_URL="https://sparkylinux.org/forum/"                                                                                         
BUG_REPORT_URL="https://sourceforge.net/p/sparkylinux/tickets"


cat /etc/apt/sources.list.d/sparky.list                                                                             
cat: /etc/apt/sources.list.d/sparky.list: No such file or directory 

lami07

#4
/etc/apt/sources.list is wrong.  Replace its content with:
deb http://deb.debian.org/debian/ bullseye main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye main contrib non-free
deb http://deb.debian.org/debian-security/ bullseye-security/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ bullseye-security/updates main contrib non-free
deb http://deb-multimedia.org/ bullseye main non-free

## Other repos can be found in /etc/apt/sources.list.d directory ##



Next run
sudo apt update
sudo apt install sparky6-apt



After that run
sudo apt update
sudo apt upgrade
sudo apt full-upgrade
Quote from: forum rulesWhen an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at [url="//irc.freenode.net"]irc.freenode.net[/url]

mdre808

Thanks a mille! Initially, my first sparky linux was the stable one. Nevertheless, I changed it to this semi-rolling one, which might cauese this problem. By the way, I am a Chinese, so forgive me for my bad writting. In spite of my loaction, the web-brower always waits for long (30m, I think) as I am browsing this website: I often got running out of my patiience,so to ask for help of solving the problem had to be put off . So great help, you've solved the problem that confused me quiet a long period of time and thanks a lot !

View the most recent posts on the forum