Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: <SOLVED> GIMP problems  (Read 178 times)

Offline niftyprose

  • Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
<SOLVED> GIMP problems
« on: October 17, 2020, 04:48:01 pm »
Hello guys, I'm a long-time user of The GIMP. I don't much like the GNU image processor, but I have always found it reliable and stable.

I'm on an Asus E200H and I just installed Sparky 5.12 Nibiru, stable, LXQt version. I've removed some pieces of software that I don't use via Synaptic and added Catfish, The GIMP, Inkscape, Scribus, Chromium, Claws, Teams, Skype, Zoom, gFTP, Geany. In other words, a pretty conservative install.

Everything works OK *except* that The GIMP is very unstable -- it crashes on pretty much any operation.

Suspect I'm not the only one and that there must be a fix?

NP.
« Last Edit: October 21, 2020, 09:37:44 am by niftyprose »

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 252
  • Karma: +5/-0
    • Sparky Community Repos
Re: GIMP problems
« Reply #1 on: October 17, 2020, 05:42:17 pm »
Run gimp in terminal and post error message you will get next time GIMP crushes
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline niftyprose

  • Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
Re: GIMP problems
« Reply #2 on: October 17, 2020, 07:22:59 pm »
Voila. Thanks, iami07. NP

_____

iftyprose@niftynetbook2:~$ gimp

(gimp:12659): Gtk-WARNING **: 18:21:32.156: Unable to locate theme engine in module_path: "murrine",

(file-jpeg:12687): Gtk-WARNING **: 18:21:42.470: Unable to locate theme engine in module_path: "murrine",
The program 'gimp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 24146 error_code 3 request_code 18 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(script-fu:12674): LibGimpBase-WARNING **: 18:21:50.006: script-fu: gimp_wire_read(): error
niftyprose@niftynetbook2:~$

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 252
  • Karma: +5/-0
    • Sparky Community Repos
Re: GIMP problems
« Reply #3 on: October 17, 2020, 08:26:33 pm »
Try installing gtk2-engines-murrine
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline niftyprose

  • Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
Re: GIMP problems
« Reply #4 on: October 18, 2020, 07:36:48 pm »
Worked perfectly. Thanks, Iami07!

How come I needed to install the theme engine? GIMP is popular and I'd have expected it to run right away.

Best, WM.

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 252
  • Karma: +5/-0
    • Sparky Community Repos
Re: GIMP problems
« Reply #5 on: October 18, 2020, 08:39:56 pm »
GIMP like vast majority of software you will find on Linux distro like Sparky uses system theming. Apparently your active gtk theme requires murrine theme engine to play well with GIMP.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline niftyprose

  • Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
Re: <SOLVED> GIMP problems
« Reply #6 on: October 21, 2020, 09:39:07 am »
Thx, Lami07. This problem is actually a first for me, likely because my choice of OS and apps is so conservative... Best, NP