Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Cannot install RTL8188FU Wifi Driver

Started by wantit, October 28, 2020, 05:06:25 AM

Previous topic - Next topic


I have installed SparkyLinux (sparkylinux-5.12-x86_64-xfce) on a Lenovo M55 PC. For Wifi I am using a USB dongle that uses the Realtek rtl8188fu driver. However the OS does not recognize this device. It does not have a Wifi driver for it. I tried using the instruction from the following webpage :- . First I tried doing it using the Manual commands but the 'sudo dkms build rtl8188fu/1.0 ' command failed, with :- your kernel headers for kernel 4.19.0-9-amd64 cannot be found at /lib/modules/4.19.0-9-amd64/build or  /lib/modules/4.19.0-9-amd64/source . I then tried to add it from a repository as shown in the webpage. I could not add the ppa:kelebek333/kabosuz repository. However I then install Linux Lite ( linux-lite-5.0-64bit ) and once again the Wifi driver rtl8188fu was missing. I then added the repository as called out in the above webpage and installed the driver without any problems. I am now using Linux Lite, but would like to go back to SparkyLinux if I can install the Realtek rtl8188fu Wifi driver. Dows anybody have any ideas?


As it says "command failed your kernel headers for kernel 4.19.0-9-amd64 cannot be found " it looks like you needed to install the relevant linux headers package.

sudo apt install linux-headers-4.19.0-9-amd64

If it comes back with other errors look for the packages it says are missing - possibly cmake.

Looking at the ppa he has used ndiswrapper which allows linux to make use of windows drivers.

Alternatively you could hurl the Realtek dongle out of the window and fit a PCI wifi card???


Posting the output of "inxi -bnr"  never hurts.   Let your machine do some of the talking.   Get the xml right and use the # button.
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

View the most recent posts on the forum