Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: cannot install qbittorrent  (Read 907 times)

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
cannot install qbittorrent
« on: November 17, 2020, 04:19:22 am »
After I upgrade the system to "bullseyses 64", qbittorrent disapeared. I did install it back, but it can not be installed. And there are many "tasks" that it did not finish; if I install it back , may it "restore" these downloading tasks automatically, or I had to do somethingelse to keep, or all the unfinished tasks wiil be lost?

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
Re: cannot install qbittorrent
« Reply #1 on: November 17, 2020, 06:10:31 am »
What could I do?

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 307
  • Karma: 6
    • Sparky Community Repos
Re: cannot install qbittorrent
« Reply #2 on: November 17, 2020, 08:18:35 am »
Why qbittorrent can not be installed? Whats an error ?
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
Re: cannot install qbittorrent
« Reply #3 on: November 17, 2020, 08:46:22 am »
Then ( after I upgraded to bullseye),when I plugged the smart phone, it did not connect to PC as before as an USB, it just did recharge the battery, no matter I chooes every prompt option on the smart phone.  What should I do ?

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
Re: cannot install qbittorrent
« Reply #4 on: November 17, 2020, 08:54:35 am »
It says:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qbittorrent : Depends: libtorrent-rasterbar10 (>= 1.2.5) but it is not installable
E: Unable to correct problems, you have held broken packages.

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
Re: cannot install qbittorrent
« Reply #5 on: November 17, 2020, 09:41:12 am »
Ideally, qbittorrent would be installed back with its full remining tasks.

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 307
  • Karma: 6
    • Sparky Community Repos
Re: cannot install qbittorrent
« Reply #6 on: November 17, 2020, 10:14:54 am »
Remaining tasks should be ok. But first we have to fix broken dependency. I will post update on the situation soonTM.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 307
  • Karma: 6
    • Sparky Community Repos
Re: cannot install qbittorrent
« Reply #7 on: November 17, 2020, 10:51:34 am »
Ok. Dependency issue should be fixed now. Run sudo apt update and try to install qbittorent once more.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline mdre808

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 0
Re: cannot install qbittorrent
« Reply #8 on: November 17, 2020, 11:40:05 am »
now qbittorrent is back. I try some ways, suddenly I recognized that it required something like "10"th version; and I just knew something like gcc8,9 and 10. So a 10 must require a 10, that will be fair. AferI installed ggc10 and other related pacages, I tried to install qbittorrent again, It can be installed this time!
Althought I do not know how and why, I just guess and (hopefully well) resolved this problem. But this next promblem is not now.: the smart cell phones(mine and friend's) cannot act like a USB as before( appeared as MTP). This is not a great issue,stil would be much inconvenient.  I will appreciate you, allora ,grazia a mille!

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 307
  • Karma: 6
    • Sparky Community Repos
Re: cannot install qbittorrent
« Reply #9 on: November 17, 2020, 11:59:48 am »
Quote
(...) I try some ways, suddenly I recognized that it required something like "10"th version; and I just knew something like gcc8,9 and 10. So a 10 must require a 10, that will be fair. AferI installed ggc10 and other related pacages (...)
Incorrect. Gcc had nothing to do with your issue. Qbittorrent requires libtorrent-rasterbar10 which is missing in Debian testing repo. To fix that we added libtorrent-rasterbar10 to sparky repo. Thats is. Missing dependency fixed.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net