Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

how to disable touchscreen?

Started by drspastic, October 11, 2020, 10:12:48 PM

Previous topic - Next topic

drspastic

so i have this old cf19 laptop that wont die. after the last cocktail was poured into it the touchscreen started making random moves and even after disassembly and cleaning. unplugging doesnt help because the wires still pick up static or something. i used to run ubuntu and could do xinput command to disable device 9 which was touchscreen.
now i have installed sparky and its running well but i cant disable touch because sparky doesnt use xinput.
how do i disable it? preferably some way tat i can add to startup script, or some way tat doesnt involve recompiling the kernel to remove touch support.

thanks


ps. i have never spilt a drink in my life. james... you are a prize plum!

pavroo

Check here:
https://vitux.com/disable-touchpad-when-mouse-is-connected-to-your-debian-10-system/
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

manyroads

Here's a script I use...

#!/bin/bash
#Touchpad on/off toggle script with notification.
#by ManyRoads http://eirenicon.org

if synclient -l | egrep "TouchpadOff.*= *0" ; then
    synclient TouchpadOff=1
    DISPLAY=:0 notify-send \
               --urgency=normal \
               --icon=/usr/share/icons/HighContrast/32x32/status/touchpad-disabled.png \
               "Touchpad Disbled"
else
    synclient TouchpadOff=0
    DISPLAY=:0 notify-send \
               --urgency=normal \
               --icon=/usr/share/icons/HighContrast/32x32/devices/input-touchpad.png \
               "Touchpad Enabled";
fi
exit 0;
dwm & i3wm ~Reg. Linux User #449130

View the most recent posts on the forum