Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

<SOLVED> Canon Laser Printer i-Sensys LBP7010C does not print.

Started by nemomen, September 03, 2020, 01:08:40 PM

Previous topic - Next topic


Hello everybody over there!
I feel so Hannibal ante portas, but nevertheless Rome wins anyway. The question is why?
SW:. SparkyLinux Xfce 5.12 Nibiru Sid.
HW: inxi:
CPU: Dual Core Intel Core i3-3220 (-MT MCP-)
speed/min/max: 1595/1600/3300 MHz Kernel: 4.19.0-10-amd64 x86_64 Up: 2m
Mem: 708.5/7668.1 MiB (9.2%) Procs: 182 Shell: bash 5.0.3 inxi: 3.0.32

Subject: Canon Laser Printer i-Sensys LBP7010C does not print.

The printer works properly under all kind of Windows, but does not print under all kind of Linux distros I had ever tried. The best solution is the solution of SparkyLinux, but the printer does not print. See details.

I do remember to opened a topic on the same subject previously and closed, when I had found on the website of Apple localhost:631 no driver for this printer. In the meantime they had uploaded this driver, but it does not work (at last at me).

Some details and steps have been taken yet.
Any source of the steps are the followings:
▪ Canon LBP 2020/imprimante_canon_capt2 [Wiki ubuntu-fr].html and so on.

▶ Download the driver. Available:
Check thoroughly the Readme file and recommends of Canon. Take your steps if necessary.
The cable is connected, the printer is turned off. Generally be root.
▶ Install the driver.
It is necessary to use the 32-bit driver on 64-bit PC, too. (The 64-bit driver has not been installed by lack of dependencies).
First: install the cndrvcups-common_3.21-1_i386.deb package.
While install by Gdebi the package requires about 75 dependencies to download and install.
Second: install the cndrvcups-capt_2.71-1_i386.deb package.
While install by Gdebi the package requires about 2 dependencies to download and install.
Any of the steps I had taken yet:
▶ Then use the command in terminal ls -l /dev/usb/lp* /dev/bus/usb/*/* to define the output possible: /dev/usb/lp0 and/or /dev/usb/lp1.
▶ Then check data by command sudo usb_printerid /dev/usb/lp0 or /lp1 in terminal.
It would be a similar one: GET_DEVICE_ID string: MFG:Canon;MDL:LBP7010C/7018C;CMD:CAPT;VER:3.0;CLS:PRINTER;DES:Canon LBP7010C/7018C
▶ Then run the command of: sudo /etc/init.d/cups restart
The result would be like that:
[ ok ] Restarting cups (via systemctl): cups.service.
▶ To start CUPS immediately, issue the following command: root (sudo) #systemctl start cups
▶ Then root (sudo) #systemctl enable cups for automatically booting.
▶ Then check the cups by ls /usr/share/cups/model/ | grep CNCUPS
▶ Then register the printer: sudo /usr/sbin/lpadmin -p Canon-LBP7010C-7018C -m CNCUPSLBP7018CCAPTK.ppd -v ccp://localhost:59687
[Some source tells localhost:59787; 59787 -; 59687 -E; 59787 -E and others. None of them works].
▶ Then run sudo /usr/sbin/ccpdadmin -p Canon-LBP7010C-7018C -o /dev/usb/lp1 and/or /lp0
It would be similar like the follows:
CUPS_ConfigPath = /etc/cups/
LOG Path        = None
UI Port         = 59787
Entry Num  : Spooler   : Backend   : FIFO path      : Device Path    : Status
  •     : Canon-LBP7010C-7018C    : usb       : //Canon/LBP7010C/7018C?serial=XXX    : /dev/usb/lp1
    ▶ Then run: sudo /etc/init.d/ccpd start
    The result would be: Starting /usr/sbin/ccpd:
    Open the printer settings and check the printer in it. Turn on the printer and check it in the printer settings window. Take the necessary steps, if needs.
    ▶ Then run: sudo service ccpd start
    ▶ Then run: sudo service ccpd status
    The result would be similar like the follows:
    ● ccpd.service
       Loaded: loaded (/etc/init.d/ccpd; generated)
       Active: active (exited) since XXX; XXs ago
       Docs: man:systemd-sysv-generator(8)
       Process: 10248 ExecStart=/etc/init.d/ccpd start (code=exited, status=0/SUCCESS)
       systemd[1]: Starting ccpd.service...
       ccpd[10248]: Starting /usr/sbin/ccpd: .
       systemd[1]: Started ccpd.service.
    It looks like good when "active" (running or exited). Please use "q" if necessary to leave.
    ▶ Then run: captstatusui -P Canon-LBP7010C-7018C
    It would shows many similar messages like: Gtk-WARNING **: : Unable to locate theme engine in module_path: "murrine" and so on. And a pop-up window opens.
    The pop-up window must shows Sleeping or Ready to print. Then it could check the consumables, the counter, and to initialize and calibrate the printer. It is also possible to clean it. The cleaning paper is the only paper was printed by the LBP7010C at me under any Linux distro until so far. What a wonderful result after thousands of years!
    In case you're not seeing the Ready to Print and it is asking to check the cables properly, simply turn off the printer and switch on again. Then run the command captstatusui P Canon-LBP7010C-7018C again for checking the status of the printer.
    Then close the pop-up window. This means returning to the terminal, close it, if not needs any more.
    ▶ AND HERE IS THE UNKNOWN PROBLEM FOR ME: in spite of the "Sleeping" or "Ready to print" status, when I should like to print anything, like test pages, documents in any formats and others, I always received the following message: ccp send_data error, exit and the printer does print nothing. The printing line shows restraining and it is a must the cancel the job for continuing anyway.
    All the things tell the story of Hannibal ante portas to me, but the printer does not print, so Rome wins.
    Would you be so kind to furnish me with information, which steps I had taken wrong, or which steps must take to solve the problem of: ccp send_data error, exit.
    Although I had tried others steps of installation, none of them works. Usually I have got a message "finished", but the printer did print nothing.
    ▶ Known further problems:
    - while shutting down, it is a never ending story any time, so I am forced to made the shutting down manually, but it is not interesting now.
    - the other printers are using cups as well, but the HP printer does not print with the driver supplied by the OS. It is a must to delete and install an other way of cups.
    See details on the website of: (requires Google box).
    Maybe it is serious problem, if printing with Canon LBP7010C depends on it, because the HP is the default printer.

    Thanks for your efforts in advance.

    No proposals for solving the problem have been arrived yet, so I am closing this topic right now, and forget Canon products forever.

View the most recent posts on the forum