Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: firejail fails with firefox  (Read 147 times)

Offline majpooper

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
firejail fails with firefox
« on: June 29, 2020, 03:24:00 pm »
I cannot get firefox started with firejail . . . .  any ideas what is going on?
Code: [Select]
sparky@macbook:~$ firejail firefox
Reading profile /etc/firejail/firefox.profile
Reading profile /etc/firejail/whitelist-usr-share-common.inc
Reading profile /etc/firejail/firefox-common.profile
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/disable-exec.inc
Reading profile /etc/firejail/disable-interpreters.inc
Reading profile /etc/firejail/disable-programs.inc
Reading profile /etc/firejail/whitelist-common.inc
Reading profile /etc/firejail/whitelist-var-common.inc
Warning: networking feature is disabled in Firejail configuration file
Parent pid 114354, child pid 114355
Warning: An abstract unix socket for session D-BUS might still be available. Use --net or remove unix from --protocol set.
Post-exec seccomp protector enabled
Seccomp list in: !chroot, check list: @default-keep, prelist: unknown,
Child process initialized in 138.71 ms
Warning: an existing sandbox was detected. /usr/bin/firefox will run without any additional sandboxing features

Parent is shutting down, bye...

here is my rig if that helps
Code: [Select]
sparky@macbook:~$ spark
System:    Kernel: 5.6.0-2-amd64 x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: LXQt 0.14.1
           Distro: SparkyLinux 6 (Po-Tolo) base: Debian bullseye/sid
Machine:   Type: Laptop System: Apple product: MacBook7,1 v: 1.0 serial: <filter>
           Mobo: Apple model: Mac-F22C89C8 serial: <filter> UEFI: Apple v: MB71.88Z.0039.B0E.1111071359
           date: 11/07/11
Battery:   ID-1: BAT0 charge: 55.0 Wh condition: 57.6/62.9 Wh (92%) model: DP bq20z451 status: Discharging
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/M235 charge: 5% (should be ignored)
           status: Discharging
CPU:       Topology: Dual Core model: Intel Core2 Duo P8600 bits: 64 type: MCP arch: Penryn rev: A
           L2 cache: 3072 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 9557
           Speed: 796 MHz min/max: 798/2394 MHz Core speeds (MHz): 1: 994 2: 1200
Graphics:  Device-1: NVIDIA MCP89 [GeForce 320M] vendor: Apple driver: nouveau v: kernel bus ID: 02:00.0
           Device-2: Apple Built-in iSight type: USB driver: uvcvideo bus ID: 1-6:3
           Display: x11 server: X.Org 1.20.8 driver: nouveau note: display driver n/a
           resolution: 1280x800~60Hz
           OpenGL: renderer: NVAF v: 3.3 Mesa 20.1.1 direct render: Yes
Audio:     Device-1: NVIDIA MCP89 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:08.0
           Sound Server: ALSA v: k5.6.0-2-amd64
Network:   Device-1: NVIDIA MCP89 Ethernet vendor: Apple driver: forcedeth v: kernel port: 22a0
           bus ID: 00:09.0
           IF: eth0 state: down mac: <filter>
           Device-2: Broadcom and subsidiaries BCM43224 802.11a/b/g/n vendor: Apple AirPort Extreme
           driver: bcma-pci-bridge v: N/A port: 2280 bus ID: 01:00.0
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
           IF-ID-2: wlan0 state: up mac: <filter>
Drives:    Local Storage: total: 232.89 GiB used: 15.66 GiB (6.7%)
           ID-1: /dev/sda vendor: Hitachi model: HTS545025B9SA02 size: 232.89 GiB
Partition: ID-1: / size: 224.27 GiB used: 15.66 GiB (7.0%) fs: ext4 dev: /dev/sda2
Swap:      ID-1: swap-1 type: partition size: 3.73 GiB used: 0 KiB (0.0%) dev: /dev/sda3
           ID-2: swap-2 type: zram size: 1024.0 MiB used: 57.8 MiB (5.6%) dev: /dev/zram0
           ID-3: swap-3 type: zram size: 128.0 MiB used: 62.7 MiB (49.0%) dev: /dev/zram1
Sensors:   System Temperatures: cpu: 30.4 C mobo: N/A gpu: nouveau temp: 57 C
           Fan Speeds (RPM): N/A
Info:      Processes: 141 Uptime: 17h 02m Memory: 1.69 GiB used: 870.2 MiB (50.2%) Init: systemd runlevel: 5
           Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 inxi: 3.1.03

Offline 151tom

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: firejail fails with firefox
« Reply #1 on: July 08, 2020, 03:15:22 am »
Did you install firejail profiles when you installed firejail.

I don't know why or understand why on some Debian based distros the only way to get firejail to work is to install firejail profiles.

Hope this helps.
I'm grumpy because I can be not because I'm old.