Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

The repository ' testing Release' no longer...

Started by blargh, June 27, 2020, 11:09:28 AM

Previous topic - Next topic


I have Sparky Linux on an old seldom used box and I am trying to update it this weekend. I get this message when I run apt update. It appears I am on Bullseye. I don't have much experience with upgrading distros but I did mange to correct the Debian testing/updates to testing-security.

The repository ' testing Release' no longer has a Release file.

My Sparky sources show:

### sparky unstable repository
deb unstable main
deb-src unstable main

### sparky testing repository
### used as default by all sparky editions
deb testing main
deb-src testing main

How should I proceed?


Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Ah yes, I see now that lsb_release -a says (po-tolo) so I can use one of those repos. I got hung up with codename bullseye.


That helped somewhat but now I have a version issue.

$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gnustep-base-runtime : Depends: gnustep-base-common (= 1.27.0-3) but 1.26.0-6 is to be installed
libgnustep-base1.27 : Depends: gnustep-base-common (= 1.27.0-3) but 1.26.0-6 is to be installed
E: Broken packages


Right, so I solved it by removing the problematic package, then upgrading everything, and afterwards install gnustep-common (or whatever) again.

View the most recent posts on the forum