Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: Hello from NC USA  (Read 733 times)

Offline majpooper

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Hello from NC USA
« on: June 26, 2020, 05:20:09 pm »
I am retired US Army (26 years) and have also worked in the private sector in software engineering but I am by to stretch of the imagination have developer or coding skills or experience. I have simply been a linux user for about 10 years. I switched to linux because I am a cheapskate and secondarily because I was getting frustrated with Windows. I took a course in linux at the local CC where we used SuSe which I felt was too hard to use as a daily driver. A classmate suggested Ubuntu which seemed much better to be - mind you I fully understand linux distros are purely a matter of personal needs and preferences so I avoid the "Ford vs Chevy" type arguments. Anyway I ended up on Mint as my daily driver. But I find myself helping folks more and more who need help with their PCs and laptops. I show them linux and if they want want install linux for them and in some cases function as there support - I have done this 8 times so far and provide differing levels of support. Now I find I am being asked if I can bring back to life some very old resource challenged PCs and laptops (example a MacBook with an intel 2 core CPU with 2Gb RAM). I want a minimal OS Debian based not bloated with software that is not needed - hence Sparky. However I may need a little guidance configuring Minimal Sparky. I am going to test in a VM first before I ask for any help but just want to introduce myself first as I get started.   

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 754
  • Karma: +3/-0
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: Hello from NC USA
« Reply #1 on: June 27, 2020, 12:56:30 am »
A man, a plan, a canal.  Panama

Detail orientated people always welcome.  As stated elsewhere, I recommend qemu/kvm for virtualization, it has come a long way since 2016 when I  did virtualbox in frustration.     For help, inxi is your friend when posting.  Good to checksum the iso.   And for older kit, if the calamares install does not  work out, go with the advanced installer. 

For the lightest DE xfce is it imho,  however LXQT  is  not that much heavier and also uses xfmw4 for windowing.    For testing - rolling for the lightest of light, Sway as a tiling manager with Wayland for video is nice, but too geeky by 1/2 for most people. 

For web browsing it is becoming  very apparent to me that old atom processors and 1 GB memory  does not cut it anymore.   Possibly finding out how to spoof as a cell phone...   
And the devil that you will have to deal with  on old kit, is it the software or the old hardware.   

This machine is dying. 

Code: [Select]
inxi -fbr
System:    Host: sway Kernel: 5.6.0-2-686-pae i686 bits: 32 Desktop: sway 1.4 Distro: Debian GNU/Linux bullseye/sid
Machine:   Type: Laptop System: Acer product: Aspire one v: V1.27 serial: <superuser/root required>
           Mobo: Acer model: Aspire one v: V1.27 serial: <superuser/root required> BIOS: Acer v: 1.27 date: 03/01/2010
Battery:   ID-1: BAT0 charge: 1.1 Wh condition: 18.4/24.4 Wh (76%)
CPU:       Topology: Single Core model: Intel Atom N270 bits: 32 type: MT L2 cache: 512 KiB
           Speed: 798 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1011 2: 1028
           Flags: acpi aperfmperf apic arch_perfmon bts clflush cmov constant_tsc cpuid cx8 de ds_cpl dtes64 dtherm dts
           est fpu fxsr ht lahf_lm mca mce mmx monitor movbe msr mtrr nx pae pat pbe pdcm pebs pge pni pse sep ss sse
           sse2 ssse3 tm tm2 tsc vme xtpr
Graphics:  Device-1: Intel Mobile 945GSE Express Integrated Graphics driver: i915 v: kernel
           Device-2: Chicony 4-Port Hub type: USB driver: uvcvideo
           Display: server: X.Org 1.20.8 driver: i915 note: display driver n/a resolution: 1024x600~60Hz
           OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.1.2
Network:   Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k
           Device-2: Qualcomm Atheros AR8132 Fast Ethernet driver: atl1c
Drives:    Local Storage: total: 178.77 GiB used: 13.83 GiB (7.7%)
Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb http://mirror.steadfast.net/debian/ unstable main contrib non-free
           2: deb-src http://mirror.steadfast.net/debian/ unstable main contrib non-free
Info:      Processes: 140 Uptime: 40m Memory: 926.7 MiB used: 504.6 MiB (54.4%) Shell: bash inxi: 3.1.03

running sid with Sway on a SDHC card, the flip side of grub is a 120 gb hdd has a 4 y.o Sparky testing lxqt or I3  Power input is loose via age and recently it will have a green cast over it at times. 

If you were getting tens or hundereds of the same kit I might recommend another distro - but for one of this and one of that, Sparky will work.   Welcome and come kick our tires.

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline majpooper

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Hello from NC USA
« Reply #2 on: June 28, 2020, 12:40:02 am »
THX much for the welcome - I pretty much hang out on the Mint forum. I have not really setup any low resource laptops for anyone until this MacBook came along.  I once loaded lubuntu on my wife's old Mac Mini 5 or 6 years ago but that was just idle play. So I am really interested if I can get the MacBook in a usable state for just basic use - browser/office/email.

LXQt seems OK so far although I will have to check a few other light DE. I added zram and tried to speed up Firefox as much as I could - I guess I could try a lighter fork of FF or Chrome to see if they are any snappier. Just as a creature of habit I use FF.

Anyway thx again and any suggestions would be appreciated as this new ground for me as I am usually installing Mint cinnamon or a refurbished Lenovo laptop or HP Pavillion PC or some such with an i5 and 8 to 16Gb of RAM   
Code: [Select]
sparky@macbook:~$ inxi -Fxz
System:    Kernel: 5.6.0-2-amd64 x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: LXQt 0.14.1
           Distro: SparkyLinux 6 (Po-Tolo) base: Debian bullseye/sid
Machine:   Type: Laptop System: Apple product: MacBook7,1 v: 1.0 serial: <filter>
           Mobo: Apple model: Mac-F22C89C8 serial: <filter> UEFI: Apple
           v: MB71.88Z.0039.B0E.1111071359 date: 11/07/11
Battery:   ID-1: BAT0 charge: 55.9 Wh condition: 57.6/62.9 Wh (92%) model: DP bq20z451
           status: Full
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/M235
           charge: 5% (should be ignored) status: Discharging
CPU:       Topology: Dual Core model: Intel Core2 Duo P8600 bits: 64 type: MCP arch: Penryn
           rev: A L2 cache: 3072 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 9556
           Speed: 796 MHz min/max: 798/2394 MHz Core speeds (MHz): 1: 796 2: 796
Graphics:  Device-1: NVIDIA MCP89 [GeForce 320M] vendor: Apple driver: nouveau v: kernel
           bus ID: 02:00.0
           Device-2: Apple Built-in iSight type: USB driver: uvcvideo bus ID: 1-6:3
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
           resolution: 1280x800~60Hz
           OpenGL: renderer: NVAF v: 3.3 Mesa 20.1.1 direct render: Yes
Audio:     Device-1: NVIDIA MCP89 High Definition Audio driver: snd_hda_intel v: kernel
           bus ID: 00:08.0
           Sound Server: ALSA v: k5.6.0-2-amd64
Network:   Device-1: NVIDIA MCP89 Ethernet vendor: Apple driver: forcedeth v: kernel port: 22a0
           bus ID: 00:09.0
           IF: eth0 state: down mac: <filter>
           Device-2: Broadcom and subsidiaries BCM43224 802.11a/b/g/n
           vendor: Apple AirPort Extreme driver: bcma-pci-bridge v: N/A port: 2280
           bus ID: 01:00.0
           IF-ID-1: wlan0 state: up mac: <filter>
Drives:    Local Storage: total: 232.89 GiB used: 15.51 GiB (6.7%)
           ID-1: /dev/sda vendor: Hitachi model: HTS545025B9SA02 size: 232.89 GiB
Partition: ID-1: / size: 224.27 GiB used: 15.51 GiB (6.9%) fs: ext4 dev: /dev/sda2
Swap:      ID-1: swap-1 type: partition size: 3.73 GiB used: 0 KiB (0.0%) dev: /dev/sda3
           ID-2: swap-2 type: zram size: 1024.0 MiB used: 0 KiB (0.0%) dev: /dev/zram0
           ID-3: swap-3 type: zram size: 128.0 MiB used: 0 KiB (0.0%) dev: /dev/zram1
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A gpu: nouveau temp: 58 C
           Fan Speeds (RPM): N/A
Info:      Processes: 138 Uptime: 6m Memory: 1.69 GiB used: 826.6 MiB (47.7%) Init: systemd
           runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 inxi: 3.1.03
« Last Edit: June 28, 2020, 02:47:15 am by majpooper »