Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: [SOLVED]Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB  (Read 860 times)

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Hello all first post here. Also my first dive into the world of Linux since Win 7 support is ending. Have been thinking of switching forever anyways.

So I'll save you all the initial issues I had first. Such as installing Debian(Buster) in it's entirety cause Sparky install attempt said kernal was missing. Did that Debian installed, but will not boot. But now my live USB Sparky GameOver is booting and loading.

The issue I kept having with Calamares installer was the partitions. No matter how I set them up or let the installer set them up it would install to a point and give me errors with "Jobs" of partitions to make. Below is only one I wrote down...

Need Partition 512MB /DEV/SDA
Create file system FAT 32 on /DEV/SDA1
Command mkfs.fat -f32 -l -v

It also asked me in other attempts to setup an unformatted 8MB grub partition.

No matter what partition setups I tried the installer would spit out new contridictory "Jobs" to install Sparky.

So now I'm running the advanced installer it started up fine, time was set correctly, but it has been running a good 3+hrs to setup on 2TB hdd... Is it stuck should I reboot and try again?

My motherboard is a Gigabyte GA-Z170MX-GAMING 5  board. The HDD is a Seagate 2TB 5400rpm I believe. I have 16GB of high performance RAM.

Oh yeah I also had a ton of issues with debian installer not recognizing my CD-ROM mid install...

What am I doing wrong? Can someone lay out how to partition the drive? I don't want a dual boot I'm just installing Sparky WIN 10 is gone dont want it.

Oh yeah I also disabled my AMD 5500 XT and am installing via onboard video as Debian installer was not having it.
« Last Edit: June 09, 2020, 06:51:04 am by Kyanite393 »

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #1 on: June 08, 2020, 12:54:55 am »
And yes I turned off boot security in bios.

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #2 on: June 08, 2020, 05:27:43 am »
See below results of my latest attempts. Everytime I start install it warns me it should be GPT, but that's not how the installer set it up itself... im completely lost going nuts.

Every failure it gives me that list of what I need to do, I do my best to do it and it doesn't work and I get a new list of what I should have done. Can anyone help me please!?

This attempt was after I tried using Calamares again with erase option and a 17.1 Gib linuxswap. Calamares setup the failed partition. I had to cancel the install after it hung at 30% for over an hour.

Sorry you're just gonna have to click links to see photos cause the [img httpblahblah.com[\img]http://does not work.



PARTITION SETUP
https://www.flickr.com/photos/188797102@N03/shares/Sh33p0

INSTALL SUMMARY
https://www.flickr.com/photos/188797102@N03/shares/13wo37

FAILURE RESULTS/INSTRUCTIONS
https://www.flickr.com/photos/188797102@N03/shares/x23366

PLEASE HELP! I've been at this for three straight days now...

« Last Edit: June 08, 2020, 06:29:38 am by Kyanite393 »

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 293
  • Karma: +5/-0
    • Sparky Community Repos
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #3 on: June 08, 2020, 08:36:04 am »
Hi. If I were you I would go with:
- GPT partition scheme
- 512MB fat32 /EFI/boot
- 16GB swap
- 60GB system partition ''/''
- ''/home'' partition - rest of the hard drive

Install bootloader on the device (/dev/sda),  instead of system partition.

BIOS-grub partition is not needed on system with UEFI
« Last Edit: June 08, 2020, 08:51:48 am by lami07 »
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #4 on: June 08, 2020, 09:19:56 am »
Thank you will try that.

I am going to get this to work I don't care how long I'm banging my head on the wall.

Much appreciated.
« Last Edit: June 08, 2020, 09:27:29 am by Kyanite393 »

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 293
  • Karma: +5/-0
    • Sparky Community Repos
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #5 on: June 08, 2020, 09:29:17 am »
''/' and ''/home'' can be every filesystem supported by linux, but I highly recommend ext4
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #6 on: June 08, 2020, 08:56:58 pm »
You're suggestions got me to a higher % of install to 40% to be exact. But no matter the % Calamares always gets stuck of copying/unpacking/writing the live image to the HDD at 102238/225940 in the image writing process. That number used to be at 30% I got past 30% to 40% but it hung on that exact same number of the install process.

GParted Summary: I put in the mount points you noted, but this shows post install hang cancel that it wrote to some tmp/ folders some data... so its getting somewhere just won't finish.
https://www.flickr.com/photos/188797102@N03/shares/7Q6Mn1

It forced that esp flag on the fat32 partition... does the swap partition even need the swap flag? Do other partitions require certain flags?

There's a setting in my bios for OS's can set it to Win 8/10 or "Other OSs" I've tried it both ways.
I also tried the above partition scheme adding the 8mb unformatted grub_bios it tells me GPT partitions require...

Internet not connected during install either. Advanced installer hung for a whole day, Calamares overnight. It lays out and formats the partitions super fast then when it comes to unpacking/writing the live image it freezes up at above mentioned point.

What else could I be doing wrong. The USB Flashes the whole install till it gets to that point then just the Tower LEDs blink and the USB no longer flashes its red light.... and install hangs/freezes...

I tried turning on/off a bunch of legacy crap in my bios, I don't know why it won't keep going...

Do any of the partitions require flags?

Also you meant /boot/efi for FAT32 not /EFI/Boot right?


Thanks to any and all for any help.
« Last Edit: June 09, 2020, 02:16:12 am by Kyanite393 »

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #7 on: June 08, 2020, 09:32:25 pm »
I checked the file system of the USB and the "Root" folder has a little red X next to it and cannot be opened.

Right click properties displays some errors... Flickr link below...

https://www.flickr.com/photos/188797102@N03/shares/Ak75oP

Is my USB Live image the problem?

I'm currently attempting to make a new live usb from this live system using terminal and bs=4M dd all that. I first formatted the usb with gparted to GPT file system and am currently mounting newly downloaded in this live environment gameover ISO... then im gonna see if that USB works... Only thing I can think of to try different atm...
« Last Edit: June 08, 2020, 11:28:35 pm by Kyanite393 »

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #8 on: June 09, 2020, 01:09:42 am »
Okay so my terminal attempt in live environment to create a new live usb seems to be not working can someone review my syntax? Or maybe just isn't posssible making live partition usb of the same live environment im in...?? Who knows? The USB I'm attempting to create is blinking indicating some activity, but it's been maybe 2hrs now...

I've watched like 15 videos on doing this through terminal and read several websites... so I did try my best...

Please let me know if somethings out of order. I dragged and dropped in the if=location and removed the ' ' marks on each end that copies in when you do it that way.

Syntax:
live@live:~$ sudo dd if=/home/live/Downloads/sparkylinux-2020.05-x86_64-gameover.iso of=/dev/sdc bs=4M

Terminal Image: With lsblk info as well
https://www.flickr.com/photos/188797102@N03/shares/hxA4s4

the ^C and [[D occured from me trying to highlight and ctrl+c copy the syntax out of the terminal. Maybe that ruined process?

I heard linux likes information in bits of 4 so that's why I did that.... dunno if I missed some other syntax or it's out of order or making live USB in a live USB environment isnt possible?

Again thanks to any and all for any help....   :o
« Last Edit: June 09, 2020, 01:21:07 am by Kyanite393 »

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #9 on: June 09, 2020, 02:12:41 am »
I gave up on that plan after about 4 hours. Now I'm running fdisk to check for bad sectors...

 sudo e2fsck -cfpv /dev/sda1

Can take hours I hear... I'll continue to update any progress and failed attempts. I am going to get this working.

I have a brand new WD Black 2TB disc just in case, but I don't want to blow that up if I've blown this one up... that's where I'm at currently.

Should I just try a lighter sparky distro?? Any input appreciated greatly.
« Last Edit: June 09, 2020, 02:18:59 am by Kyanite393 »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 754
  • Karma: +3/-0
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #10 on: June 09, 2020, 02:56:35 am »
Asking questions to make sure I understand.

1.  Are you setting up a USB stick with the live version of Sparky?  Guessing it is 2020.05 GameOver. 

the "dd if = ....     of=...    bs-4m|   can be used to set up the USB disk.      this is done from a linux machine.

  Success would be booting up the Live version on the usb and it is running on your computer - showing that it is very likely Sparky will work on your computer.

2.   Are you then trying to install the live Version to your computer?  I apologize if I am in error.      But the output of the dd  command looks like it is stuck       The other screenshot has   Live  under places   and a root folder of 7.8 gb           On my stable system my /root 3.1 MB

Below in my disk usage on a very minimal system  10 year old atom   
Code: [Select]
    6.1 GiB [##########] /home
    3.7 GiB [######    ] /usr
    1.5 GiB [##        ] /var
   75.4 MiB [          ] /boot
    6.2 MiB [          ] /etc
    2.5 MiB [          ]  core
. 904.0 KiB [          ] /run
  188.0 KiB [          ] /root
   96.0 KiB [          ] /tmp
e  16.0 KiB [          ] /lost+found

Been awhile since I ha ve insatllled..    I downloaded the Sparky game over and installed in a virtualbox sandbox.    The live install screen came up with a desktop came up and I  clicked on install.  English.   Guided.  and it is unpacking. 

So if your live usb gets you  to a desktop similar to as found on wiki.sparkylinux.org/docu.php/calamares    you just double click install. 
 
If I was doing it myself I would use the advanced installer and the partition sizes that Iami07 gave you.

While it installed you posted again.  If you do not have a very new machine with a very new board I would suggest you start with stable.

My favouriite of course is lxqt   You will still have many options under sparkys repos to add all sorts of things. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #11 on: June 09, 2020, 03:13:40 am »
This machine's less than a year old, the video card less than a month.

I have a current rolling Sparky Live USB that is loading up but then upon attempting to install to the HDD from the live environment with calamares or advanced it just gets stuck after creating the partitions and attempting to write the live image to the HDD. It ALWAYS gets stuck at 102238/225940 of the image unpacking process.

So either my live usb image is flawed, im doing something wrong, or I blew up the HDD or who knows?

The Live USB of sparky gameover 2020.05 loads everytime without a hitch, however it would not do so till I first installed debian on the HDD kept saying kernal was missing...

HDD has had several formats and partition attempts to get the Live USB Image to install to the HDD, no matter what always hangs at 102238/225940....

The root you're seeing on my HDD is from previous failed attempts of installing sparky gameover having to cancel mid image unpacking... so it gets some data on the HDD and gets stuck at the same exact point every time no matter what I try.

Screen of System Info:
https://www.flickr.com/photos/188797102@N03/shares/YSK3Ag

The HDD is a Seagate Firecuda 2TB currently being checked for bad sectors as noted above.

Calamares I've tried the "erase" option "manual" and I've also attempted gparted and advanced installer several times...

What I'm Currently attempting fdisk:
https://www.flickr.com/photos/188797102@N03/shares/9Lgcg6

Thanks for reply.
« Last Edit: June 09, 2020, 03:24:31 am by Kyanite393 »

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #12 on: June 09, 2020, 03:28:18 am »
My grandpa was a computer tech, and took me to work with him from like the age of five. He even taught me binary math...

So I'm not a complete tool, just all my knowledge is windows/dos

Like I've used fdisk before in dos to repair computers... glad there's something similar hope it works as good as dos version.

Complete novice anything Linux or MAC
« Last Edit: June 09, 2020, 03:40:57 am by Kyanite393 »

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #13 on: June 09, 2020, 04:35:03 am »
My motherboards driver download website says...

 1. Due to different Linux support condition provided by chipset vendors, please download Linux driver from chipset vendors' website or 3rd party website.

Chipset according to manual: Has no linux drivers...
https://downloadcenter.intel.com/product/90591/Intel-Z170-Chipset

https://www.gigabyte.com/Motherboard/GA-Z170MX-Gaming-5-rev-11/support#support-dl-driver-sataraidahci

Maybe I'm just not compatable... is this not possible then?

Manual for the MB also does not list Linux as supported... don't know how that would stop writing to the HDD though? and why live is working and booting?

Someone successfully installed MAC OS to same MB though... and that's nothing like windows/dos
https://www.tonymacx86.com/threads/ga-z170mx-gaming-5-high-sierra-install-success.238376/
« Last Edit: June 09, 2020, 04:50:32 am by Kyanite393 »

Offline Kyanite393

  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
Re: Sparky GameOver Partitioning/Install Issues UEFI Dual Bios MB
« Reply #14 on: June 09, 2020, 04:56:16 am »
Man this is the first and only machine I've built with an Intel CPU/MB what a terrible decision...

I've always been all about AMD... but this was before ryzen and they were falling back..

This says it's possible though... ahh problems I cant solve kill me!
https://www.theregister.com/2016/09/02/windows_intel_kaby_lake_amd_zen

Excerpt from above site:
One example of Microsoft holding back support is the xHCI USB controller in sixth-generation Skylake and seventh-generation Kaby Lake: Windows 7 doesn't support that USB hardware, so installing the operating system from a USB stick using those chips is tricky. Intel provides xHCI drivers for Windows 7 once it's up and running.

So intel put something in their chipsets to frag loading other OS's from USB???
« Last Edit: June 09, 2020, 05:04:58 am by Kyanite393 »