Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

[SOLVED] After installation no Grub2

Started by facciofinta, April 02, 2020, 06:54:28 PM

Previous topic - Next topic


I've installed SparkyLinux (Dual Boot with an Ubuntu Studio partition and a Windows partition).
At start the grub2 is not founded.
I could access to all the OS thanks to Super Grub2 Disk but how can I repair the grub?
Here the info thanks to GParted:


Can I use the SparkyLinux live USB to boot in EFI mode and reinstall Grub?



This worked for me:
Download rEFInd boot manager at
I've chosen the "USB flash drive image file" of rEFInd
Then find your usable usb-stick
sudo fdisk -l
For me it was detected
Disk /dev/mmcblk0: 1,9 GiB, 1973420032 bytes, 3854336 sectors
unmount it
umount /dev/mmcblk0
copy the .img file of rEFInd
sudo dd if=/home/USER/ETCETERA/refind-flashdrive-0.12.0/refind-flashdrive-0.12.0.img of=/dev/mmcblk0
then restart computer with boot option to the UEFI on that usb-stick
now navigate the beautiful rEFInd panel - look for "install rEFInd on your computer"

that's it!


I sometimes check howtos for age and appropriateness

aptitude show refind
Package: refind                         
Version: 0.11.3-1
State: not installed
Priority: optional
Section: admin
Maintainer: Rod Smith <>
Architecture: amd64
Uncompressed Size: 4,654 k
Depends: debconf, efibootmgr, openssl, parted, debconf (>= 0.5) | debconf-2.0

nice find.  web page was updated in March of 2020  It is in debian repositories, so vetted.  I choose to not help with grub2, one can only do so much. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

View the most recent posts on the forum