Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum https://forum.linuxiarze.pl

no wifi connection DELL XPS 13 9343

Started by facciofinta, April 02, 2020, 12:54:42 PM

Previous topic - Next topic

facciofinta

Hi,
I've a DELL XPS 13 9343, with Broadcom BCM4352 Card Wif- adapter.

Accordingo to https://wiki.debian.org/InstallingDebianOn/Dell/Dell%20XPS%2013%209343 I've installed broadcom-sta-source package, but wifi is still not working.
Someone can help me? thanks

pavroo

Does it help for you:
https://forum.sparkylinux.org/index.php/topic,2550.msg3913.html
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux.org at irc.libera.chat

facciofinta

Thanks.
I've installed broadcom-sta-dkms and uninstalled broadcom-sta-source.
sudo apt-get remove broadcom-sta-source
sudo apt-get install broadcom-sta-dkms

(Network Manager was already installed).
According to https://tutorialforlinux.com/2020/01/01/step-by-step-debian-buster-install-broadcom-wifi-driver-offline-easy-guide/ I loaded the Broadcom Wifi Driver:
sudo modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
sudo modprobe wl

but this is the result:
modprobe: FATAL: Module wl not found in directory /lib/modules/4.19.0-6-amd64
and:
sudo iwconfig
lo        no wireless extensions.


thank in advance

facciofinta

I've updated the whole system through Synaptic but the problem is unchanged:
sudo modprobe wl
modprobe: FATAL: Module wl not found in directory /lib/modules/4.19.0-6-amd64

and no wifi connection

View the most recent posts on the forum