Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: no wifi connection DELL XPS 13 9343  (Read 445 times)

Offline facciofinta

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
no wifi connection DELL XPS 13 9343
« on: April 02, 2020, 12:54:42 pm »
Hi,
I've a DELL XPS 13 9343, with Broadcom BCM4352 Card Wif- adapter.

Accordingo to https://wiki.debian.org/InstallingDebianOn/Dell/Dell%20XPS%2013%209343 I've installed broadcom-sta-source package, but wifi is still not working.
Someone can help me? thanks

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2149
  • Karma: +2/-0
    • SparkyLinux
Re: no wifi connection DELL XPS 13 9343
« Reply #1 on: April 02, 2020, 02:14:00 pm »
Does it help for you:
https://forum.sparkylinux.org/index.php/topic,2550.msg3913.html
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline facciofinta

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: no wifi connection DELL XPS 13 9343
« Reply #2 on: April 02, 2020, 05:28:39 pm »
Thanks.
I've installed broadcom-sta-dkms and uninstalled broadcom-sta-source.
Code: [Select]
sudo apt-get remove broadcom-sta-source
sudo apt-get install broadcom-sta-dkms
(Network Manager was already installed).
According to https://tutorialforlinux.com/2020/01/01/step-by-step-debian-buster-install-broadcom-wifi-driver-offline-easy-guide/ I loaded the Broadcom Wifi Driver:
Code: [Select]
sudo modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
sudo modprobe wl
but this is the result:
Code: [Select]
modprobe: FATAL: Module wl not found in directory /lib/modules/4.19.0-6-amd64and:
Code: [Select]
sudo iwconfig
lo        no wireless extensions.

thank in advance

Offline facciofinta

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
Re: no wifi connection DELL XPS 13 9343
« Reply #3 on: April 04, 2020, 09:14:20 am »
I've updated the whole system through Synaptic but the problem is unchanged:
Code: [Select]
sudo modprobe wl
modprobe: FATAL: Module wl not found in directory /lib/modules/4.19.0-6-amd64
and no wifi connection