Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: CAM repository ?  (Read 366 times)

Offline Mito77

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
CAM repository ?
« on: March 21, 2020, 10:32:46 pm »
Hi anyone,

I search a repo for install CAM Software, like ardour, rosegarden... On my sparky. And I need the software like on this list :

https://linuxmao.org/Cat%C3%A9gorie+s%C3%A9quenceurs

Offline lami07

  • Global Moderator
  • Full Member
  • *****
  • Posts: 229
  • Karma: +2/-0
    • Sparky Community Repos
Re: CAM repository ?
« Reply #1 on: March 22, 2020, 02:31:10 pm »
Hi. Yesterday I answered your question on our IRC channel. Apps you asked for are already part of debian repo. Sparky utilizes debian repo directly. For example to install ardour run this commands
Code: [Select]
sudo apt update
sudo apt install ardour

Same goes for rosegarden.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline Mito77

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: CAM repository ?
« Reply #2 on: March 23, 2020, 09:10:34 pm »
Alright, it work good, and I install Hydrogen... I need more software, but I found that audacity don't work with qjackctl, and I can't connect my jack microphone, with qjackctl or with ardour... I try a lot of channel. Now I want to try sparkylinux in english, because all tutorials is not on my language (french).

I need to read all man page of this software, or the manual on some forums. Thank you for the help !

Ah, and I don't have realtime kernel with sparkylinux.

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 735
  • Karma: +3/-0
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: CAM repository ?
« Reply #3 on: March 23, 2020, 11:45:40 pm »
posting the output "inxi -brA" is helpful.   Use the code button above (#) to format the output.

If you are in Spakry6 -Rolling-testing - you very well might have problems with the migration away from Python 2 happening in Rollng-Testing.  Others would know more.   

peace out. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline Mito77

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: CAM repository ?
« Reply #4 on: March 24, 2020, 08:54:59 am »
Hi,

Code: [Select]
~$ inxi -brA
System:
  Host: julmot-pc Kernel: 4.19.0-6-amd64 x86_64 bits: 64
  Desktop: Xfce 4.12.4 Distro: SparkyLinux 5.10 (Nibiru)
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC
  v: 088A120000305910000620100 serial: <root required>
  Mobo: Hewlett-Packard model: 188F v: 70.25 serial: <root required>
  UEFI [Legacy]: Insyde v: F.26 date: 02/21/2013
Battery:
  ID-1: BAT0 charge: 42.9 Wh condition: 42.9/42.9 Wh (100%)
CPU:
  Dual Core: AMD E2-1800 APU with Radeon HD Graphics type: MCP
  speed: 1322 MHz min/max: 850/1700 MHz
Graphics:
  Device-1: AMD Wrestler [Radeon HD 7340] driver: N/A
  Display: x11 server: X.Org 1.20.4 driver: ati,vesa
  unloaded: fbdev,modesetting,radeon resolution: 1368x768~N/A
  OpenGL: renderer: llvmpipe (LLVM 7.0 128 bits) v: 3.3 Mesa 18.3.6
Audio:
  Device-1: AMD Wrestler HDMI Audio driver: snd_hda_intel
  Device-2: AMD FCH Azalia driver: snd_hda_intel
  Sound Server: ALSA v: k4.19.0-6-amd64
Network:
  Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet
  driver: r8169
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
Drives:
  Local Storage: total: 3.41 TiB used: 857.90 GiB (24.6%)
Repos:
  Active apt repos in: /etc/apt/sources.list
  1: deb http://deb.debian.org/debian/ buster main contrib non-free
  2: deb-src http://deb.debian.org/debian/ buster main contrib non-free
  3: deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
  4: deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free
  5: deb http://deb.debian.org/debian/ buster-updates main contrib non-free
  6: deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free
  7: deb http://www.deb-multimedia.org/ buster main non-free
  No active apt repos in: /etc/apt/sources.list.d/dropbox.list
  No active apt repos in: /etc/apt/sources.list.d/liquorix.list
  Active apt repos in: /etc/apt/sources.list.d/sparky-stable.list
  1: deb https://repo.sparkylinux.org/ core main
  2: deb-src https://repo.sparkylinux.org/ core main
  3: deb https://repo.sparkylinux.org/ stable main
  4: deb-src https://repo.sparkylinux.org/ stable main
Info:
  Processes: 153 Uptime: 41m Memory: 3.46 GiB used: 1019.7 MiB (28.8%)
  Shell: bash inxi: 3.0.32

And Of course, I can't install exaile-plugin-moodbar, and the repo is  jessie (oldoldstable) : https://packages.debian.org/fr/jessie/exaile-plugin-moodbar

Do I need to create source list, for add repo, and "apt update" after ?

is it in /etc/apt/sources.list or /etc/apt/sources.list.d/ ?  The command add-apt-repository work ? thank you for the help.

And I don't have this because I don't have the key :

Code: [Select]
Réception de :19 http://deb.debian.org/debian-security buster/updates/main amd64 Packages [183 kB]
Err :8 https://repo.sparkylinux.org core InRelease                 
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 5CA76B26C40956B8


Err :10 https://repo.sparkylinux.org stable InRelease                         
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 5CA76B26C40956B8

I can't install exaile-plugin-moodbar 3.4.0.2-1 , I can't downgrade because it's the last version on the repo, for exaile 4.0.2-1

How to have the good version of exaile for install the plugin ? thx.

Here the link for this github : https://github.com/exaile/moodbar/releases (Moodbar) and for the jessie : https://packages.debian.org/fr/jessie/sound/ , and Github exaile : https://github.com/exaile
« Last Edit: March 24, 2020, 09:08:06 am by Mito77 »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 735
  • Karma: +3/-0
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: CAM repository ?
« Reply #5 on: March 25, 2020, 02:57:39 am »
Sparky 5  - so no problems with the change over in Python

Computer is from about 2013, so problems with new hardware that needs better firmware. 

No ubuntu repositores - thanks, good.  That is one way to really mess up a computer.

That is the limit of my expertise on this one.     


Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.

Offline Mito77

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: CAM repository ?
« Reply #6 on: March 25, 2020, 05:42:34 am »
for change language of my distro I have this and It work !

Code: [Select]
sudo dpkg-reconfigure locales
But I can't modify setting for ardour and qjackctl know my microphone jack...

Sorry but I'm noob, I need to search some tutorials

And I can't downgrade exaile ...

Offline Mito77

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: CAM repository ?
« Reply #7 on: March 26, 2020, 02:44:02 am »
Hi ! My installation of Sparkylinux is broken, I have add repo testing of debian for trying to install some .deb with no make install. Like falcon, dillo, and other web browser alternative for chromium and firefox-esr , my bad, I'm very noob, I can't boot on my distro Sparkylinux, and I can't view TTY when I do ctrl + alt + F1 or ctrl + Alt + f2 . I have a problem with libgc6. :-\

And I want to try slackware for studio production, or studioware . But, I don't know if I can repair my old installation of sparkylinux, do I need LiveCD for reinstall Sparky linux ? So I need to recreate an USB key for that. Because my computer don't read CDROM at the boot (with the bios UEFI). :P

Here we can found the list of basic software for linux audio : http://www.linux-sound.org/one-page.html#midi

« Last Edit: March 26, 2020, 02:49:20 am by Mito77 »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 735
  • Karma: +3/-0
  • https://forum.sparkylinux.org/index.php/topic,4614
Re: CAM repository ?
« Reply #8 on: March 27, 2020, 12:41:09 am »
Did you look at the date of the linux.sound page     
Quote
Musings June/July 2006
       To the best of my time/ability  that is the date I believe of the source you quote.  If that is correct you are going to be in a time warp.   

You have to be able to walk before you can run.  Whatever you do, start with a stable distribution.  You can if you want re-install Sparky5.  You do not have to use cd, you can use a cheap 4 Gb usb flash drive.  I would strongly recommend a totally clean install. 

Get it running.  Learn either aptus or the command line methods of updating.  XFCE is a good choice.
Read and read.

For an example, 
https://wiki.debian.org/FrontPage?action=fullsearch&context=180&value=sound&titlesearch=Titles

See how many of the ones listed have very very old dates.  Whatever you are going to use for sources of information,  check the date. 

My knowledge of kernels is far from expert, but much improvement has happened in the last decades for the latency of kernels.  4.19 might work. I do not know, but the amount of memory might have more effect than tweaking the kernel. 

Walk first.  Grabbing source code and compiling is a lot of work and can have unintended outcomes. 

You mention wanting to try a few different light weight browsers.  falcon, dillo, etc.  Security of browsers just keeps getting harder for the small light ones.  If you want less info leaving your computer and fewer security problems, learn firejail and run firefox-esr with it.  I used to runi midori 2015-2016 on Sid, liked it well enough, but they shut it down because it was too hard to keep up with security.  They have restarted.  Dillo is still available.  Falcon is not.  Short answer - if you can not install a program via aptus or via apt  (it is the same 10.000 plus programs), just don't until you have more experience.  But you can install midori or dillo and try them out, just use the system tools you have been given.   


 



Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.