Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

Rescue ISO Does Not Boot

Started by yogi, February 23, 2020, 07:01:14 PM

Previous topic - Next topic


    Model: Msi GL72 7QF
    Processor: Intel i7-7700HQ; 2.8GH
    RAM: 16GB DDR4
    GPU onboard: Intel(R) HD Graphics 630
    GPU card: nVidia GTX960M, Optimus enabled
    SSD: 500GB, GPT UEFI
    INSTALLED OS: Windows10 Insider Preview; Mageia 7; Ubuntu 18.04.3 LTS
Secure boot and fast boot: disabled

I want to install sparkylinux-2020.02-x86_64-rescue.iso onto a SanDisk 16GB USB3 memory stick.  I used Rufus 3.8 in the dd copy mode to install, and also used mkusb (in Ubuntu) during a previous attempt.  The results are the same regardless: the boot sequence begins but never completes.  Typically it ends with a black screen, or a flashing underscore cursor. 

I'm certain the problem is with the fact that I have an nVidia graphics card in my laptop.  I tried all the available boot options in the Grub menu, but it all ends the same way.  I added nouveau.noaccel=1 and nouveau.modeset=0 to the Grub kernel commands and that generally works with other Linux distributions but not with this rescue .iso copy. 

I know that Sparky will run on this laptop because I have the desktop sparky Linux (ver 5.10 Nibiru) installed and working on a separate USB memory stick.  I believe I used a virtual machine to create that UEFI installation, but I'm not sure.  I also don't recall what I did, if anything, to get around the nVidia card issue.  It just works.

Any suggestions for how to get around the boot problem for the rescue.iso will be greatly appreciated.


I do not have nvidia so can give no help there.

It has been near decades since I triple booted FreeBSD, Mandrake and Windows98.  But after the hdd died, I chose to focus more on my job and only did 2 OSes.  Triple booting can be a chore. 

So, either the Sparky rescue iso installed onto the usb or it did not.  Did you checksum? 
In irc many would say, no, not rufus, just use dd on the terminal. And checksum.   
My guess is that the rescue iso does proceed in bootup to a place to be able to rescue your system.  Have any other rescue iso's worked , which ones worked?

You mention virtualization.  You most probably have one great machine to use virtualization.  Check your cpu flags.  "inxi -f" will show. No need to post.  vmx is the flag for intel that is crucial to speed up.  That would lead to a decision of which OS to use to host the virtualization.  kvm/qemu versus virtualbox also.  My two cents is to use kvm/qemu especially for linux and BSD.    Good luck

Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


paxmark1 ~
Thank you for your response.  I have been a dedicated Windows fan for more years than I like to count.  Linux has become of interest to me in the past few years as a possible alternative, which is why I have been experimenting with multiple operating systems installed side by side.  UEFI seems to be more of a challenge than the old MBR system, but that is not my problem at the moment.  Just booting at all is a problem with the Sparky Rescue installation.

I have no problem installing Sparky, either the desktop or the rescue version, onto a USB memory stick.  My desktop computer runs Windows 7 with virtualbox and that is what I use to create the USB memory sticks.  The VM environment isolates the Linux installation from the rest of the computer and thus makes creating a UEFI installation safe and easy.  Nobody gets hurt that way.  LOL

The Sparky Desktop was installed successfully to USB memory and runs well when I boot it from my laptop (specified in the opening post of this thread).  Sparky Rescue, however, is a live version and does not boot at all.  The splash screen shows that the boot process begins, but it always hangs at some point and never completes.  I can in fact run Sparky Rescue in that VirtualBox on the other computer, but when I install it to USB and plug it into the laptop it fails.  That is how I know it is a good download. I believe the reason is that two different graphics drivers are involved.  The nVidia driver is what is needed for the laptop and that is what will not boot properly.

I cannot run inxi until I get Sparky up and running.  That is part of the challenge here.  I can't install the nVidia drivers either because I have not been able to even call up a console in the text boot mode.  Even if I could access the console, the live version ISO is read only.  The usual tricks that work with other Linux distros do not seem to be working here.  I need to learn some new tricks.  ;)

View the most recent posts on the forum