Advertising

Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum Linuxiarze.pl

Author Topic: sddm error  (Read 467 times)

Offline constantius

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
sddm error
« on: January 02, 2020, 09:47:20 pm »
Hi
I have unexpected error when system tried load SDDM-
output from /var/log/user.log
Code: [Select]
Jan  2 21:20:26 pentiumg4600 sddm[776]: Authentication error: "Process crashed"
21:20:26 pentiumg4600 sddm[776]: Auth: sddm-helper crashed (exit code 15)

output from /var/log/debug
Code: [Select]
Jan  2 20:50:55 pentiumg4600 sddm-helper[1188]: [PAM] returning.
Jan  2 20:50:55 pentiumg4600 sddm-greeter[860]: Message received from daemon: LoginFailed
Jan  2 20:50:55 pentiumg4600 sddm-helper[1188]: [PAM] Ended.

output from boot.log
Code: [Select]
Starting Terminate Plymouth Boot Screen...
/dev/sdb2: clean, 224102/2818048 files, 1929647/11263744 blocks
[FAILED] Failed to mount /home/radek/DrugiHD.
See 'systemctl status home-radek-DrugiHD.mount' for details.

That is strange because fstab is correct
/dev/sdb1   /home/radek/DrugiHD    ext4   defaults 0 2
and DrugiHD is correct detected and load

After boot or reboot system go into emergency mode
SDDM is not loaded

This error appearance in unexpected way ( I never know when it be ) Sometimes system boot normal without it

Sparky LINUX Semi-rolling LXQT desktop amd64

you can answer in Polish
« Last Edit: January 02, 2020, 10:28:03 pm by lami07 »

Offline lami07

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 252
  • Karma: +5/-0
    • Sparky Community Repos
Re: sddm error
« Reply #1 on: January 02, 2020, 10:34:01 pm »
Run the command below and paste the result.
Code: [Select]
sudo systemctl status home-radek-DrugiHD.mount
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline constantius

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: sddm error
« Reply #2 on: January 02, 2020, 10:40:37 pm »
Code: [Select]
radek@pentiumg4600:~$ sudo systemctl status home-radek-DrugiHD.mount
[sudo] hasło użytkownika radek:
● home-radek-DrugiHD.mount - /home/radek/DrugiHD
     Loaded: loaded (/etc/fstab; generated)
     Active: active (mounted) since Thu 2020-01-02 21:20:47 CET; 1h 18min ago
      Where: /home/radek/DrugiHD
       What: /dev/sdb1
       Docs: man:fstab(5)
             man:systemd-fstab-generator(8)
      Tasks: 0 (limit: 9326)
     Memory: 364.0K
     CGroup: /system.slice/home-radek-DrugiHD.mount
radek@pentiumg4600:~$

everything seems to be ok ...
« Last Edit: January 03, 2020, 09:23:34 pm by lami07 »

Offline constantius

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: sddm error
« Reply #3 on: January 03, 2020, 07:29:45 pm »
any advise? What is wrong?