Welcome to SparkyLinux forums
Zapraszamy również na polsko-języczne Forum

<SOLVED> Problems installing virtualbox

Started by wybren, December 01, 2019, 06:26:23 PM

Previous topic - Next topic


Dear all,

When I try to install VirtualBox through the usual way it won't succeed. The terminal tells me the installation can't complete because libvpx5 (>= 1.6.0) is missing. The Aptus way of installing doesn't succeed either.

Any ideas on solving this one?

Thanks in advance!


It will help if you tell us what version of SparkLinux you are using and what exactly is "your" usual way of installing, CLI-apt, Synaptic, Aptitude, dpkg etc etc.?


Thanks for the info. Will be fixed. For now I advice to install virtualbox from debian unstable repo instead of sparky repo.
Quote from: forum rulesWhen an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at [url="//"][/url]


Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Unless I missed something, poster still has not stated which Sparky, especially rolling or stable. 

As always, posting the output of inxi -br wouid be quite sufficient. 

For myself in Debian stable  etc/apt/source...
deb bionic contrib

the bionic contrib was truncated off of the end via the forum software/ 
For rolling or unstable, I would go with the posters above.

Virtualbox tracks Ubuntu more, but I have not had problems in Virtualbox since Stretch was in early testing (2016).  "bionic" would be the version name for stable and lts.

Side issue.  qemu/kvm had hiccups with Windows 7 in 2015 so I went with virtualbox.  My license for 7 keeps me in virtualbox for ease.  If I ever go to 10 for moms finances, I would go with qemu/kvm. It has matured enough.  Virtual box spends more effort in supporting Ubuntu and RedHat variants.  Debian does take the high and  soemtimes very high road on FOSS.  There can be hiccups, especially in testing. 
Search forum for "More info easier via inxi"    If requested -  no inxi, no help for you by  me.


Your absolutely right, for your info: I'm on the latest semi-rolling xfce release.

The missing package is now in the repository, so installation could start.

However, the next error message popped up:

This system is currently not set up to build kernel modules.
Please install the Linux kernel "header" files matching the current kernel
for adding new hardware support to the system.
The distribution packages containing the headers are probably:
    linux-headers-amd64 linux-headers-5.2.0-3-amd64

The first was already installed (linux-headers-amd64), the latter could not be found.

System:    Host: sparky-envy Kernel: 5.2.0-3-amd64 x86_64 bits: 64 Desktop: Xfce 4.14.1 Distro: SparkyLinux 6 (Po-Tolo)
Machine:   Type: Laptop System: HP product: HP ENVY Laptop 13-ad1xx v: Type1ProductConfigId serial: <root required>
           Mobo: HP model: 83A7 v: KBC Version 39.33 serial: <root required> UEFI: Insyde v: F.18 date: 11/02/2017
Repos:     Active apt repos in: /etc/apt/sources.list
           1: deb testing main contrib non-free
           2: deb-src testing main contrib non-free
           3: deb testing-security/updates main contrib non-free
           4: deb-src testing-security/updates main contrib non-free
           5: deb testing main non-free
           6: deb [arch=amd64] buster contrib
           No active apt repos in: /etc/apt/sources.list.d/dropbox.list
           No active apt repos in: /etc/apt/sources.list.d/liquorix.list
           No active apt repos in: /etc/apt/sources.list.d/sid.list
           Active apt repos in: /etc/apt/sources.list.d/sparky-testing.list
           1: deb core main
           2: deb-src core main
           3: deb testing main
           4: deb-src testing main
           Active apt repos in: /etc/apt/sources.list.d/sparky-unstable.list
           1: deb unstable main
           2: deb-src unstable main


Your kernel is:
QuoteHost: sparky-envy Kernel: 5.2.0-3-amd64
The present one is: 5.3.0-2 so make full upgrade of your system, install kernel headers 5.3.0-2, then reboot your machine using the new kernel and try again.
Nothing is easy as it looks. Danielle Steel
Join at [url="//"][/url]


Thanks it is solved now. I had the latest kernel installed, but I assumed my grub was automatically updated, which was not the case. So I had to first upgrade my grub and login loading the right kernel.

Solved now. Many thanks for the help

View the most recent posts on the forum